summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMonsta <[email protected]>2015-01-15 22:17:35 +0300
committermonsta <[email protected]>2015-06-09 16:04:58 +0300
commit77ab4ec17fb5bb45d6d1246f96fdf44ff5da9790 (patch)
tree1b0066261ee617a115c646b251b7c63931df9a4a /configure.ac
parent2a0f259289472fbdd69f021aabb5b5ac48249403 (diff)
downloadmate-indicator-applet-77ab4ec17fb5bb45d6d1246f96fdf44ff5da9790.tar.bz2
mate-indicator-applet-77ab4ec17fb5bb45d6d1246f96fdf44ff5da9790.tar.xz
drop indicator-0.3 support1.8
backport of https://github.com/mate-desktop/mate-indicator-applet/commit/4c981d10d0ca6219d23ded0713912813b9c07fb3 to 1.8 branch
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 5 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index 51f489c..7661d6f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,34 +26,16 @@ m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
###########################
GTK_REQUIRED_VERSION=2.12
-INDICATOR_REQUIRED_VERSION=0.3.22
+INDICATOR_REQUIRED_VERSION=0.3.90
PKG_CHECK_MODULES(APPLET, gtk+-2.0 >= $GTK_REQUIRED_VERSION
x11
libmatepanelapplet-4.0
+ indicator-0.4 >= $INDICATOR_REQUIRED_VERSION
)
AC_SUBST(APPLET_CFLAGS)
AC_SUBST(APPLET_LIBS)
-PKG_CHECK_MODULES([INDICATOR4], [indicator-0.4 >= $INDICATOR_REQUIRED_VERSION],
- [
- AC_DEFINE([HAVE_INDICATOR4], [1], [Use Indicator 0.4])
- INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator-0.4`
- INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir indicator-0.4`
- ],
- [PKG_CHECK_MODULES([INDICATOR3], [indicator >= $INDICATOR_REQUIRED_VERSION],
- [
- AC_DEFINE([HAVE_INDICATOR3], [1], [Use Indicator 0.3])
- INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator`
- INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir indicator`
- ])
-])
-
-AC_SUBST(INDICATOR4_CFLAGS)
-AC_SUBST(INDICATOR4_LIBS)
-AC_SUBST(INDICATOR3_CFLAGS)
-AC_SUBST(INDICATOR3_LIBS)
-
###########################
# Check to see if we're local
###########################
@@ -68,6 +50,9 @@ AC_ARG_ENABLE(localinstall, AS_HELP_STRING([--enable-localinstall], [install all
if test "x$with_localinstall" = "xyes"; then
INDICATORDIR="${libdir}/indicators/2/"
INDICATORICONSDIR="${datadir}/indicator-applet/icons/"
+else
+ INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator-0.4`
+ INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir indicator-0.4`
fi
AC_SUBST(INDICATORDIR)