summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authormonsta <[email protected]>2016-06-20 15:11:23 +0300
committermonsta <[email protected]>2016-06-20 15:11:23 +0300
commit18ecafbab727d3ccb42254f03db6cff6f6a76850 (patch)
tree5f05abb1cb56551c02f52ae65731022ea1ab3ebd /configure.ac
parent37753676942b92a8f717fad2f8cdac629c907de0 (diff)
downloadmate-indicator-applet-18ecafbab727d3ccb42254f03db6cff6f6a76850.tar.bz2
mate-indicator-applet-18ecafbab727d3ccb42254f03db6cff6f6a76850.tar.xz
GTK+3: add support for new style indicators
they don't have .so files anymore, only the service binary, and they're loaded from /usr/share/unity/indicators they're supported only with libindicator3 >= 12.10 also this adds build-dep on libido (hmm, what Freud would say?)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f6e139e..3734df0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,16 +46,28 @@ case "$with_gtk" in
esac
INDICATOR_REQUIRED_VERSION=0.3.90
+INDICATOR_NG_VERSION=12.10
INDICATOR_PKG=indicator$INDICATOR_API_VERSION-0.4
PKG_CHECK_MODULES(APPLET, gtk+-$GTK_API_VERSION >= $GTK_REQUIRED_VERSION
x11
libmatepanelapplet-4.0
)
+
AC_SUBST(APPLET_CFLAGS)
AC_SUBST(APPLET_LIBS)
-PKG_CHECK_MODULES(INDICATOR, $INDICATOR_PKG >= $INDICATOR_REQUIRED_VERSION)
+PKG_CHECK_EXISTS($INDICATOR_PKG >= $INDICATOR_NG_VERSION,
+ [have_indicator_ng="yes"],
+ [have_indicator_ng="no"])
+
+if test "x$with_gtk" = "x3.0" && test "x$have_indicator_ng" = "xyes"; then
+ PKG_CHECK_MODULES(INDICATOR, $INDICATOR_PKG >= $INDICATOR_NG_VERSION
+ libido3-0.1 >= 13.10,
+ [AC_DEFINE(HAVE_INDICATOR_NG, 1, "New style indicators support")])
+else
+ PKG_CHECK_MODULES(INDICATOR, $INDICATOR_PKG >= $INDICATOR_REQUIRED_VERSION)
+fi
AC_SUBST(INDICATOR_CFLAGS)
AC_SUBST(INDICATOR_LIBS)