summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMonsta <[email protected]>2015-01-15 22:17:35 +0300
committerStefano Karapetsas <[email protected]>2015-01-22 09:06:32 +0100
commit4c981d10d0ca6219d23ded0713912813b9c07fb3 (patch)
tree02f41c74f9b24bac45fd476561383e0daaa5b579 /configure.ac
parent0d1aee834241ffd99a122c2753ba1e6bb2247a54 (diff)
downloadmate-indicator-applet-4c981d10d0ca6219d23ded0713912813b9c07fb3.tar.bz2
mate-indicator-applet-4c981d10d0ca6219d23ded0713912813b9c07fb3.tar.xz
drop indicator-0.3 support
Closes https://github.com/mate-desktop/mate-indicator-applet/issues/10 Closes https://github.com/mate-desktop/mate-indicator-applet/pull/11
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 5 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index 70e3fc6..f75a328 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,35 +46,17 @@ case "$with_gtk" in
;;
esac
-INDICATOR_REQUIRED_VERSION=0.3.22
+INDICATOR_REQUIRED_VERSION=0.3.90
INDICATOR_PKG=indicator$INDICATOR_API_VERSION-0.4
PKG_CHECK_MODULES(APPLET, gtk+-$GTK_API_VERSION >= $GTK_REQUIRED_VERSION
x11
libmatepanelapplet-4.0
+ $INDICATOR_PKG >= $INDICATOR_REQUIRED_VERSION
)
AC_SUBST(APPLET_CFLAGS)
AC_SUBST(APPLET_LIBS)
-PKG_CHECK_MODULES([INDICATOR4], [$INDICATOR_PKG >= $INDICATOR_REQUIRED_VERSION],
- [
- AC_DEFINE([HAVE_INDICATOR4], [1], [Use Indicator 0.4])
- INDICATORDIR=`$PKG_CONFIG --variable=indicatordir $INDICATOR_PKG`
- INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir $INDICATOR_PKG`
- ],
- [PKG_CHECK_MODULES([INDICATOR3], [indicator >= $INDICATOR_REQUIRED_VERSION],
- [
- AC_DEFINE([HAVE_INDICATOR3], [1], [Use Indicator 0.3])
- INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator`
- INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir indicator`
- ])
-])
-
-AC_SUBST(INDICATOR4_CFLAGS)
-AC_SUBST(INDICATOR4_LIBS)
-AC_SUBST(INDICATOR3_CFLAGS)
-AC_SUBST(INDICATOR3_LIBS)
-
###########################
# Check to see if we're local
###########################
@@ -89,6 +71,9 @@ AC_ARG_ENABLE(localinstall, AS_HELP_STRING([--enable-localinstall], [install all
if test "x$with_localinstall" = "xyes"; then
INDICATORDIR="${libdir}/indicators/2/"
INDICATORICONSDIR="${datadir}/indicator-applet/icons/"
+else
+ INDICATORDIR=`$PKG_CONFIG --variable=indicatordir $INDICATOR_PKG`
+ INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir $INDICATOR_PKG`
fi
AC_SUBST(INDICATORDIR)