summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2011-12-24 16:51:19 +0100
committerStefano Karapetsas <[email protected]>2011-12-24 16:51:19 +0100
commit18e3f4648a7ae10486c6d65af5aa44bb9aa312a6 (patch)
tree01d1266a0cb6c949ac511366158c432a6c4a96d9 /src/Makefile.am
parente07da1c8e7e0f84d028794ef7a4fc4b190118ae8 (diff)
downloadmate-indicator-applet-18e3f4648a7ae10486c6d65af5aa44bb9aa312a6.tar.bz2
mate-indicator-applet-18e3f4648a7ae10486c6d65af5aa44bb9aa312a6.tar.xz
fixed build in debian
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am24
1 files changed, 16 insertions, 8 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 62581eb..5ebe436 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -12,7 +12,8 @@ indicator_applet_CFLAGS = \
-DINDICATOR_ICONS_DIR=\""$(INDICATORICONSDIR)"\" \
-DINDICATOR_APPLET \
-I$(srcdir)/.. \
- $(APPLET_CFLAGS)
+ $(APPLET_CFLAGS) \
+ $(INDICATOR3_CFLAGS) $(INDICATOR4_CFLAGS)
indicator_applet_SOURCES = \
applet-main.c \
@@ -22,7 +23,8 @@ indicator_applet_SOURCES = \
tomboykeybinder.h
indicator_applet_LDADD = \
- $(APPLET_LIBS)
+ $(APPLET_LIBS) \
+ $(INDICATOR3_LIBS) $(INDICATOR4_LIBS)
indicator_applet_appmenu_CFLAGS = \
-DG_LOG_DOMAIN=\""Indicator-Applet-Appmenu"\" \
@@ -31,7 +33,8 @@ indicator_applet_appmenu_CFLAGS = \
-DINDICATOR_ICONS_DIR=\""$(INDICATORICONSDIR)"\" \
-DINDICATOR_APPLET_APPMENU \
-I$(srcdir)/.. \
- $(APPLET_CFLAGS)
+ $(APPLET_CFLAGS) \
+ $(INDICATOR3_CFLAGS) $(INDICATOR4_CFLAGS)
indicator_applet_appmenu_SOURCES = \
applet-main.c \
@@ -41,7 +44,8 @@ indicator_applet_appmenu_SOURCES = \
tomboykeybinder.h
indicator_applet_appmenu_LDADD = \
- $(APPLET_LIBS)
+ $(APPLET_LIBS) \
+ $(INDICATOR3_LIBS) $(INDICATOR4_LIBS)
indicator_applet_session_CFLAGS = \
-DG_LOG_DOMAIN=\""Indicator-Applet-Session"\" \
@@ -50,7 +54,8 @@ indicator_applet_session_CFLAGS = \
-DINDICATOR_ICONS_DIR=\""$(INDICATORICONSDIR)"\" \
-DINDICATOR_APPLET_SESSION \
-I$(srcdir)/.. \
- $(APPLET_CFLAGS)
+ $(APPLET_CFLAGS) \
+ $(INDICATOR3_CFLAGS) $(INDICATOR4_CFLAGS)
indicator_applet_session_SOURCES = \
applet-main.c \
@@ -60,7 +65,8 @@ indicator_applet_session_SOURCES = \
tomboykeybinder.h
indicator_applet_session_LDADD = \
- $(APPLET_LIBS)
+ $(APPLET_LIBS) \
+ $(INDICATOR3_LIBS) $(INDICATOR4_LIBS)
indicator_applet_complete_CFLAGS = \
-DG_LOG_DOMAIN=\""Indicator-Applet-Complete"\" \
@@ -69,7 +75,8 @@ indicator_applet_complete_CFLAGS = \
-DINDICATOR_ICONS_DIR=\""$(INDICATORICONSDIR)"\" \
-DINDICATOR_APPLET_COMPLETE \
-I$(srcdir)/.. \
- $(APPLET_CFLAGS)
+ $(APPLET_CFLAGS) \
+ $(INDICATOR3_CFLAGS) $(INDICATOR4_CFLAGS)
indicator_applet_complete_SOURCES = \
applet-main.c \
@@ -79,4 +86,5 @@ indicator_applet_complete_SOURCES = \
tomboykeybinder.h
indicator_applet_complete_LDADD = \
- $(APPLET_LIBS)
+ $(APPLET_LIBS) \
+ $(INDICATOR3_LIBS) $(INDICATOR4_LIBS)