summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am82
1 files changed, 82 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..62581eb
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,82 @@
+
+libexec_PROGRAMS = \
+ indicator-applet \
+ indicator-applet-appmenu \
+ indicator-applet-session \
+ indicator-applet-complete
+
+indicator_applet_CFLAGS = \
+ -DG_LOG_DOMAIN=\""Indicator-Applet"\" \
+ -DDATADIR=\""$(datadir)"\" \
+ -DINDICATOR_DIR=\""$(INDICATORDIR)"\" \
+ -DINDICATOR_ICONS_DIR=\""$(INDICATORICONSDIR)"\" \
+ -DINDICATOR_APPLET \
+ -I$(srcdir)/.. \
+ $(APPLET_CFLAGS)
+
+indicator_applet_SOURCES = \
+ applet-main.c \
+ eggaccelerators.c \
+ eggaccelerators.h \
+ tomboykeybinder.c \
+ tomboykeybinder.h
+
+indicator_applet_LDADD = \
+ $(APPLET_LIBS)
+
+indicator_applet_appmenu_CFLAGS = \
+ -DG_LOG_DOMAIN=\""Indicator-Applet-Appmenu"\" \
+ -DDATADIR=\""$(datadir)"\" \
+ -DINDICATOR_DIR=\""$(INDICATORDIR)"\" \
+ -DINDICATOR_ICONS_DIR=\""$(INDICATORICONSDIR)"\" \
+ -DINDICATOR_APPLET_APPMENU \
+ -I$(srcdir)/.. \
+ $(APPLET_CFLAGS)
+
+indicator_applet_appmenu_SOURCES = \
+ applet-main.c \
+ eggaccelerators.c \
+ eggaccelerators.h \
+ tomboykeybinder.c \
+ tomboykeybinder.h
+
+indicator_applet_appmenu_LDADD = \
+ $(APPLET_LIBS)
+
+indicator_applet_session_CFLAGS = \
+ -DG_LOG_DOMAIN=\""Indicator-Applet-Session"\" \
+ -DDATADIR=\""$(datadir)"\" \
+ -DINDICATOR_DIR=\""$(INDICATORDIR)"\" \
+ -DINDICATOR_ICONS_DIR=\""$(INDICATORICONSDIR)"\" \
+ -DINDICATOR_APPLET_SESSION \
+ -I$(srcdir)/.. \
+ $(APPLET_CFLAGS)
+
+indicator_applet_session_SOURCES = \
+ applet-main.c \
+ eggaccelerators.c \
+ eggaccelerators.h \
+ tomboykeybinder.c \
+ tomboykeybinder.h
+
+indicator_applet_session_LDADD = \
+ $(APPLET_LIBS)
+
+indicator_applet_complete_CFLAGS = \
+ -DG_LOG_DOMAIN=\""Indicator-Applet-Complete"\" \
+ -DDATADIR=\""$(datadir)"\" \
+ -DINDICATOR_DIR=\""$(INDICATORDIR)"\" \
+ -DINDICATOR_ICONS_DIR=\""$(INDICATORICONSDIR)"\" \
+ -DINDICATOR_APPLET_COMPLETE \
+ -I$(srcdir)/.. \
+ $(APPLET_CFLAGS)
+
+indicator_applet_complete_SOURCES = \
+ applet-main.c \
+ eggaccelerators.c \
+ eggaccelerators.h \
+ tomboykeybinder.c \
+ tomboykeybinder.h
+
+indicator_applet_complete_LDADD = \
+ $(APPLET_LIBS)