summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2012-12-08 22:18:30 +0100
committerStefano Karapetsas <[email protected]>2012-12-08 22:18:30 +0100
commit4cf8fbb6f138203019c67df2db9b48f2b02cae79 (patch)
treec787d84646619b59c88fa212004e507b74a47185 /configure.ac
parente9711267ec88b5e3510f1b59796dc155ed22b156 (diff)
downloadmate-media-4cf8fbb6f138203019c67df2db9b48f2b02cae79.tar.bz2
mate-media-4cf8fbb6f138203019c67df2db9b48f2b02cae79.tar.xz
add gst-mixer-applet (moved from mate-applets package)
it will builds only if gstreamer is enabled
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 31 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6d73426..6ec2ec8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -222,6 +222,33 @@ AC_SUBST(GSTMIXER_CFLAGS)
AC_SUBST(GSTMIXER_LIBS)
AM_CONDITIONAL(HAVE_GSTMIXER, [test x$have_gstmixer = xyes])
+dnl=======================================================================
+dnl gst-mixer-applet
+dnl=======================================================================
+have_gstmixer_applet=no
+if test "x$have_gstmixer" = "xyes"; then
+ AC_ARG_ENABLE([gst-mixer-applet],
+ AC_HELP_STRING([--enable-gst-mixer-applet], [Enable the gstreamer-based mixer applet.]),
+ enable_mixerapplet=$enableval,
+ enable_mixerapplet=no)
+ if test "x$enable_mixerapplet" != "xno"; then
+ have_gstmixer_applet=yes
+ MIXER_APPLET_DEPS="gstreamer-$GST_MAJORMINOR >= $GST_REQ
+ gstreamer-interfaces-$GST_MAJORMINOR >= $GST_REQ
+ gstreamer-audio-$GST_MAJORMINOR >= $GST_REQ
+ mate-desktop-2.0 >= 1.5.0
+ ibmatepanelapplet-4.0 >= 1.5.0"
+ PKG_CHECK_MODULES(MIXER, $GST10_PKGS, have_gst_mixer_applet_deps=yes, have_gst_mixer_applet_deps=no)
+ if test "x$have_gst_mixer_applet_deps" = "xno"; then
+ have_gstmixer_applet=no
+ enable_mixerapplet=no
+ AC_MSG_ERROR([Mixer applet explicitly requested but a compatible gstreamer version was not found])
+ fi
+ fi
+ AC_SUBST(MIXERAPPLET_CFLAGS)
+ AC_SUBST(MIXERAPPLET_LIBS)
+fi
+AM_CONDITIONAL(HAVE_GSTMIXER_APPLET, test "x$have_gstmixer_applet" = "xyes")
dnl ---------------------------------------------------------------------------
dnl - Finish
@@ -309,6 +336,8 @@ gst-mixer/src/Makefile
gst-mixer/pixmaps/Makefile
gst-mixer/doc/Makefile
gst-mixer/mate-volume-control.desktop.in
+gst-mixer-applet/Makefile
+gst-mixer-applet/docs/Makefile
])
AC_OUTPUT
@@ -325,6 +354,8 @@ echo "
CFLAGS: ${CFLAGS}
PulseAudio Volume Control $have_pulseaudio
+
GStreamer mixer: $have_gstmixer
+ GStreamer mixer applet: $have_gstmixer_applet
"