summaryrefslogtreecommitdiff
path: root/data/icons/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/icons/Makefile.am')
-rw-r--r--data/icons/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/data/icons/Makefile.am b/data/icons/Makefile.am
new file mode 100644
index 0000000..67d9cea
--- /dev/null
+++ b/data/icons/Makefile.am
@@ -0,0 +1,25 @@
+NULL =
+
+SUBDIRS = \
+ scalable \
+ 16x16 \
+ 22x22 \
+ 24x24 \
+ 32x32 \
+ $(NULL)
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/mate
+
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
+update-icon-cache:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
+
+
+-include $(top_srcdir)/git.mk