summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorraveit65 <[email protected]>2016-04-05 15:32:32 +0200
committerraveit65 <[email protected]>2016-04-05 15:32:32 +0200
commit3de3b5923481488a032ddb89a7570a8ac1996874 (patch)
tree900c087cf26c2982fbefe644fe541cf9a3c5cd3e /Makefile.am
parent12913d123538dcd32d3d4dfbba168f1b81ffdcff (diff)
downloadmate-menus-3de3b5923481488a032ddb89a7570a8ac1996874.tar.bz2
mate-menus-3de3b5923481488a032ddb89a7570a8ac1996874.tar.xz
Add Changelog generation
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 758acdf..189f988 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -31,4 +31,14 @@ MAINTAINERCLEANFILES = \
$(srcdir)/m4/ltversion.m4 \
$(srcdir)/m4/lt~obsolete.m4
+# Build ChangeLog from GIT history
+ChangeLog:
+ $(AM_V_GEN) if test -d $(top_srcdir)/.git; then \
+ GIT_DIR="$(top_srcdir)/.git" git log --stat > $@; \
+ fi
+
+dist: ChangeLog
+
+.PHONY: ChangeLog
+
-include $(top_srcdir)/git.mk