summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrbuj <[email protected]>2021-01-27 11:20:33 +0100
committerraveit65 <[email protected]>2021-02-06 21:27:39 +0100
commite1431577975f16550213502f5e6767db240c5124 (patch)
treedab0a1cf9a99a194d3cf1540ae5557169f9edb80 /configure.ac
parentf831e5f9db052aec2bfa61177d0bef671cf85c6a (diff)
downloadmate-menus-e1431577975f16550213502f5e6767db240c5124.tar.bz2
mate-menus-e1431577975f16550213502f5e6767db240c5124.tar.xz
Set compiler debug flags / logging with MATE_DEBUG_CHECK
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 11 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 9a2a802..1a3713e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,17 +51,18 @@ if test "x$enable_deprecation_flags" = "xyes"; then
AC_SUBST(DISABLE_DEPRECATED_CFLAGS)
fi
-dnl --enable-debug=(yes/info/profile/no)
-AS_CASE([$ax_enable_debug],
- [yes|info], [
- DEBUG_CFLAGS="-DG_ENABLE_DEBUG"
- ],
- [no], [
+dnl ---------------------------------------------------------------------------
+dnl - logging
+dnl ---------------------------------------------------------------------------
+if test "$ax_enable_debug" = "yes"; then
+ DEBUG_CFLAGS="-DG_ENABLE_DEBUG"
+else
+ if test "x$ax_enable_debug" = "xno"; then
DEBUG_CFLAGS="-DG_DISABLE_ASSERT -DG_DISABLE_CHECKS"
- ],
- [
+ else
DEBUG_CFLAGS=""
- ])
+ fi
+fi
AC_SUBST(DEBUG_CFLAGS)
GOBJECT_INTROSPECTION_CHECK([0.6.7])
@@ -100,7 +101,7 @@ echo "
Maintainer mode: ${USE_MAINTAINER_MODE}
Use *_DISABLE_DEPRECATED: ${enable_deprecation_flags}
- Turn on debugging: ${enable_debug}
+ Turn on debugging: ${ax_enable_debug}
Build introspection support: ${found_introspection}
"