summaryrefslogtreecommitdiff
path: root/util/Makefile.am
diff options
context:
space:
mode:
authoryetist <[email protected]>2018-05-02 22:54:20 +0800
committerraveit65 <[email protected]>2018-05-27 13:44:45 +0200
commit929408351cfb8e3a9373d12c26fb96781297ab5d (patch)
tree051639676e840ecffba55c6d046d991b16986f9e /util/Makefile.am
parentedaad5228b9e23b277c1c9b3e09866f1f182054a (diff)
downloadmate-menus-929408351cfb8e3a9373d12c26fb96781297ab5d.tar.bz2
mate-menus-929408351cfb8e3a9373d12c26fb96781297ab5d.tar.xz
require gio-unix, drop python example
Diffstat (limited to 'util/Makefile.am')
-rw-r--r--util/Makefile.am15
1 files changed, 5 insertions, 10 deletions
diff --git a/util/Makefile.am b/util/Makefile.am
index ad61301..71e3e69 100644
--- a/util/Makefile.am
+++ b/util/Makefile.am
@@ -1,7 +1,7 @@
noinst_PROGRAMS = mate-menu-spec-test
AM_CPPFLAGS = \
- $(GLIB_CFLAGS) \
+ $(GIO_UNIX_CFLAGS) \
-I$(srcdir)/../libmenu \
-DMATEMENU_I_KNOW_THIS_IS_UNSTABLE \
-DMATELOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale"\" \
@@ -14,18 +14,13 @@ mate_menu_spec_test_SOURCES = \
test-menu-spec.c
mate_menu_spec_test_LDADD = \
- $(GLIB_LIBS) \
+ $(GIO_UNIX_LIBS) \
../libmenu/libmate-menu.la
-if HAVE_PYTHON
-pyexampledir = $(pkgdatadir)/examples
-pyexample_DATA = mate-menus-ls.py
-else
-pyexampledir =
-pyexample_DATA =
-endif
+exampledir = $(pkgdatadir)/examples
+example_DATA = mate-menus-ls.py mate-menus-ls.js
-EXTRA_DIST = $(pyexample_DATA)
+EXTRA_DIST = $(example_DATA)
-include $(top_srcdir)/git.mk