summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authormonsta <[email protected]>2016-04-08 12:13:29 +0300
committermonsta <[email protected]>2016-04-08 12:13:29 +0300
commit1b211be9ba2e7fe1c46b44dd00b301db867a2132 (patch)
tree9a9f7f37fb109c9aad431680561da61ab4eb8e9d /Makefile.am
parentf7ca0b92d6b61ad5f5826736d2168997a0328567 (diff)
downloadmate-netbook-1b211be9ba2e7fe1c46b44dd00b301db867a2132.tar.bz2
mate-netbook-1b211be9ba2e7fe1c46b44dd00b301db867a2132.tar.xz
fix Changelog generation
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 10 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index 1bdd776..bcea571 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,16 +7,13 @@ DISTCLEANFILES = intltool-merge intltool-update intltool-extract
MAINTAINERCLEANFILES = aclocal.m4 compile config.guess config.sub configure depcomp install-sh ltmain.sh Makefile.in missing
-dist-hook:
- @if test -d "$(srcdir)/.bzr"; \
- then \
- echo Creating ChangeLog && \
- ( cd "$(top_srcdir)" && \
- echo '# Generated by Makefile. Do not edit.'; echo; \
- $(top_srcdir)/missing --run bzr log --gnu-changelog ) > ChangeLog.tmp \
- && mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
- || (rm -f ChangeLog.tmp; \
- echo Failed to generate ChangeLog >&2 ); \
- else \
- echo Failed to generate ChangeLog >&2; \
- fi
+# Build ChangeLog from GIT history
+ChangeLog:
+ $(AM_V_GEN) if test -d $(top_srcdir)/.git; then \
+ GIT_DIR="$(top_srcdir)/.git" git log --stat > $@; \
+ fi
+
+dist: ChangeLog
+
+.PHONY: ChangeLog
+