summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorraveit65 <[email protected]>2020-04-10 18:05:46 +0200
committerraveit65 <[email protected]>2020-04-10 18:46:34 +0200
commitce0d2a510b15ef6093a8f43aaa01ef6c84707687 (patch)
tree3d43ee21208fc2e455fc72fa45ca1c682d76cc9e /configure.ac
parent5c6c1e6bdbbdf3814857bf47275c700d122be7b8 (diff)
downloadmate-netbook-ce0d2a510b15ef6093a8f43aaa01ef6c84707687.tar.bz2
mate-netbook-ce0d2a510b15ef6093a8f43aaa01ef6c84707687.tar.xz
use MATE_COMPILE_WARNINGS from mate-common
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5bedb2b..3ef78e7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,6 +7,8 @@ AC_CONFIG_MACRO_DIR([m4])
AM_CONFIG_HEADER(config.h)
AM_MAINTAINER_MODE
+MATE_COMPILE_WARNINGS
+
AC_PROG_CC
AC_STDC_HEADERS
AC_PROG_LIBTOOL
@@ -62,3 +64,17 @@ mate-window-picker-applet/Makefile
mate-window-picker-applet/org.mate.panel.applet.mate-window-picker-applet.gschema.xml
po/Makefile.in
])
+
+dnl ---------------------------------------------------------------------------
+dnl - Show summary
+dnl ---------------------------------------------------------------------------
+
+echo "
+ mate-netbook $VERSION
+ `echo mate-netbook $VERSION | sed "s/./=/g"`
+
+ prefix: ${prefix}
+ compiler: ${CC}
+ cflags: ${CFLAGS}
+ warning flags: ${WARN_CFLAGS}
+"