summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam Wold <[email protected]>2018-12-03 15:34:34 -0500
committerraveit65 <[email protected]>2018-12-05 11:36:14 +0100
commitc50f7b353fee1023e1a1236e25cc2705d482d1f6 (patch)
tree74720203a2c20ca0adb25a4c5779cf5dfbd47337 /configure.ac
parent8fe7f0c830fc444849ac8aa16a2ca9128bcc91ec (diff)
downloadmate-panel-c50f7b353fee1023e1a1236e25cc2705d482d1f6.tar.bz2
mate-panel-c50f7b353fee1023e1a1236e25cc2705d482d1f6.tar.xz
Remove legacy X11 package detection
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 1 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index 64841199..da9f172f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -169,26 +169,7 @@ gl_CHECK_TYPE_STRUCT_DIRENT_D_TYPE
dnl X development libraries check
-PKG_CHECK_MODULES(X, x11 xau, :, [
- # pkg-config modules not found (only present since X11R7 aka Xorg); use
- # old-style detection
- AC_PATH_XTRA()
- # X not found
- if test x$no_x = xyes ; then
- AC_MSG_ERROR([X development libraries not found])
- fi
-
- gp_save_cflags="$CFLAGS"
- gp_save_libs="$LIBS"
- CFLAGS="$X_CFLAGS"
- LIBS="$X_PRE_LIBS $X_LIBS $X_EXTRA_LIBS"
- AC_CHECK_LIB(X11, XFree,, AC_MSG_ERROR([libX11 not found]))
- AC_CHECK_LIB(Xau, XauFileName,, AC_MSG_ERROR([libXau not found]))
- CFLAGS="$gp_save_cflags"
- LIBS="$gp_save_libs"
-
- X_LIBS="$X_PRE_LIBS $X_LIBS -lX11 -lXau $X_EXTRA_LIBS"
-])
+PKG_CHECK_MODULES(X, x11 xau, :, AC_MSG_ERROR([X development libraries not found]))
AC_SUBST(X_LIBS)