summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam Wold <[email protected]>2019-06-17 20:10:43 +0000
committerraveit65 <[email protected]>2019-06-19 12:51:52 +0200
commitc45e92082b67c5b57a6a4a44551572882a4e6091 (patch)
treed4b245816d0569723c694d0f7ef1c7f06d572341 /configure.ac
parent517435ea0a864438509102901dbd7e177002e3f3 (diff)
downloadmate-panel-c45e92082b67c5b57a6a4a44551572882a4e6091.tar.bz2
mate-panel-c45e92082b67c5b57a6a4a44551572882a4e6091.tar.xz
Switch out wayland protocols for gtk-layer-shell dependency
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 399bd21d..c09badca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -190,12 +190,12 @@ AC_ARG_ENABLE(wayland,
[enable_wayland=$enableval],
[enable_wayland=auto])
-# Check if we have wayland-client installed, and thus should build with Wayland support
+# Check if we have gtk-layer-shell installed, and thus should build with Wayland support
have_wayland=no
if test "x$enable_wayland" != "xno"; then
- PKG_CHECK_MODULES(WAYLAND, wayland-client, have_wayland=yes, [
+ PKG_CHECK_MODULES(GTK_LAYER_SHELL, gtk-layer-shell-0, have_wayland=yes, [
if test "x$enable_wayland" = "xyes"; then
- AC_MSG_ERROR([Wayland client library not found])
+ AC_MSG_ERROR([Wayland enabled but GTK Layer Shell library not found])
fi
])
fi
@@ -206,6 +206,9 @@ if test "x$have_wayland" = "xyes"; then
AC_DEFINE(HAVE_WAYLAND, 1, [Have the Wayland development library])
fi
+AC_SUBST(GTK_LAYER_SHELL_CFLAGS)
+AC_SUBST(GTK_LAYER_SHELL_LIBS)
+
# Check if we have the X development libraries
have_x11=no
if test "x$enable_x11" != "xno"; then
@@ -309,7 +312,6 @@ mate-panel/Makefile
mate-panel/libegg/Makefile
mate-panel/libmate-panel-applet-private/Makefile
mate-panel/libpanel-util/Makefile
-mate-panel/wayland-protocols/Makefile
libmate-panel-applet/libmatepanelapplet-4.0.pc
libmate-panel-applet/libmatepanelapplet-4.0-uninstalled.pc
libmate-panel-applet/Makefile