summaryrefslogtreecommitdiff
path: root/icons/256x256/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2020-03-19 12:35:50 +0100
committerraveit65 <[email protected]>2020-03-26 17:42:50 +0100
commit2ee2dee2586564ee0957dc2e72169e2a3f12ea83 (patch)
tree447509664523610ea9b55b8a1525821304e7f4d0 /icons/256x256/Makefile.am
parent84538e0a0092980511a15de8162bd4a591045a6b (diff)
downloadmate-panel-2ee2dee2586564ee0957dc2e72169e2a3f12ea83.tar.bz2
mate-panel-2ee2dee2586564ee0957dc2e72169e2a3f12ea83.tar.xz
Add 256x256 icons
for SVG in scalable/*.svg; do file=${SVG##*/}; echo "rsvg-convert -w 256 -h 256 $SVG -o 256x256/${file%.svg}.png"; done | sh
Diffstat (limited to 'icons/256x256/Makefile.am')
-rw-r--r--icons/256x256/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/icons/256x256/Makefile.am b/icons/256x256/Makefile.am
new file mode 100644
index 00000000..eb12062e
--- /dev/null
+++ b/icons/256x256/Makefile.am
@@ -0,0 +1,34 @@
+size = 256x256
+
+iconsdir = $(datadir)/icons/hicolor/$(size)/apps
+
+icons_DATA = \
+ mate-panel-clock.png \
+ mate-panel-drawer.png \
+ mate-panel-fish.png \
+ mate-panel-force-quit.png \
+ mate-panel-launcher.png \
+ mate-panel-notification-area.png \
+ mate-panel.png \
+ mate-panel-separator.png \
+ mate-panel-window-list.png \
+ mate-panel-window-menu.png \
+ mate-panel-workspace-switcher.png
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
+update-icon-cache:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
+
+EXTRA_DIST = \
+ $(icons_DATA)
+
+-include $(top_srcdir)/git.mk