summaryrefslogtreecommitdiff
path: root/icons/48x48/Makefile.am
diff options
context:
space:
mode:
authorPerberos <[email protected]>2011-12-01 22:56:10 -0300
committerPerberos <[email protected]>2011-12-01 22:56:10 -0300
commitc51ef797a707f4e2c6f9688d4378f2b0e9898a66 (patch)
tree019ae92bb53c19b30077545cb14743cbd1b57aef /icons/48x48/Makefile.am
downloadmate-panel-c51ef797a707f4e2c6f9688d4378f2b0e9898a66.tar.bz2
mate-panel-c51ef797a707f4e2c6f9688d4378f2b0e9898a66.tar.xz
moving from https://github.com/perberos/mate-desktop-environment
Diffstat (limited to 'icons/48x48/Makefile.am')
-rw-r--r--icons/48x48/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/icons/48x48/Makefile.am b/icons/48x48/Makefile.am
new file mode 100644
index 00000000..b19e314f
--- /dev/null
+++ b/icons/48x48/Makefile.am
@@ -0,0 +1,28 @@
+size = 48x48
+
+iconsdir = $(datadir)/icons/hicolor/$(size)/apps
+
+icons_DATA = \
+ mate-panel.png
+
+icons_SOURCE = \
+ mate-panel.svg
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
+update-icon-cache:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
+
+EXTRA_DIST = \
+ $(icons_DATA) \
+ $(icons_SOURCE)
+
+-include $(top_srcdir)/git.mk