summaryrefslogtreecommitdiff
path: root/icons/64x64/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2020-03-25 19:16:33 +0100
committerraveit65 <[email protected]>2020-03-26 17:44:22 +0100
commit727dd779b37d6582500c035664b28abce186c259 (patch)
treeee2a3161393d389859682074f2998ca9667b7500 /icons/64x64/Makefile.am
parent160817958db902e5270e35b868778b2078a73a01 (diff)
downloadmate-panel-727dd779b37d6582500c035664b28abce186c259.tar.bz2
mate-panel-727dd779b37d6582500c035664b28abce186c259.tar.xz
Add 64x64 icons
for SVG in scalable/*.svg; do file=${SVG##*/}; echo "rsvg-convert -w 64 -h 64 $SVG -o 64x64/${file%.svg}.png"; done | sh
Diffstat (limited to 'icons/64x64/Makefile.am')
-rw-r--r--icons/64x64/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/icons/64x64/Makefile.am b/icons/64x64/Makefile.am
new file mode 100644
index 00000000..f08965e2
--- /dev/null
+++ b/icons/64x64/Makefile.am
@@ -0,0 +1,34 @@
+size = 64x64
+
+iconsdir = $(datadir)/icons/hicolor/$(size)/apps
+
+icons_DATA = \
+ mate-panel-clock.png \
+ mate-panel-drawer.png \
+ mate-panel-fish.png \
+ mate-panel-force-quit.png \
+ mate-panel-launcher.png \
+ mate-panel-notification-area.png \
+ mate-panel.png \
+ mate-panel-separator.png \
+ mate-panel-window-list.png \
+ mate-panel-window-menu.png \
+ mate-panel-workspace-switcher.png
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
+update-icon-cache:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
+
+EXTRA_DIST = \
+ $(icons_DATA)
+
+-include $(top_srcdir)/git.mk