summaryrefslogtreecommitdiff
path: root/applets/wncklet/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'applets/wncklet/Makefile.am')
-rw-r--r--applets/wncklet/Makefile.am14
1 files changed, 6 insertions, 8 deletions
diff --git a/applets/wncklet/Makefile.am b/applets/wncklet/Makefile.am
index d7cba006..db61f873 100644
--- a/applets/wncklet/Makefile.am
+++ b/applets/wncklet/Makefile.am
@@ -84,21 +84,19 @@ xmlui_DATA = \
showdesktop-menu.xml \
window-list-menu.xml
-gsettings_SCHEMAS = \
- org.mate.panel.applet.window-list.gschema.xml \
- org.mate.panel.applet.workspace-switcher.gschema.xml
+wncklet_gschemas_in = \
+ org.mate.panel.applet.window-list.gschema.xml.in \
+ org.mate.panel.applet.workspace-switcher.gschema.xml.in
+gsettings_SCHEMAS = $(wncklet_gschemas_in:.xml.in=.xml)
+
@INTLTOOL_XML_NOMERGE_RULE@
@GSETTINGS_RULES@
-%.gschema.xml.in: %.gschema.xml.in.in Makefile
- $(AM_V_GEN) $(SED) -e 's^\@GETTEXT_PACKAGE\@^$(GETTEXT_PACKAGE)^g' < $< > $@
-
EXTRA_DIST = \
org.mate.panel.Wncklet.mate-panel-applet.in.in \
$(service_in_files) \
$(xmlui_DATA) \
- org.mate.panel.applet.window-list.gschema.xml.in.in \
- org.mate.panel.applet.workspace-switcher.gschema.xml.in.in \
+ $(wncklet_gschemas_in) \
$(ui_DATA)
CLEANFILES = $(applet_DATA) $(applet_DATA).in $(service_DATA) $(gsettings_SCHEMAS)