summaryrefslogtreecommitdiff
path: root/applets/wncklet/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'applets/wncklet/Makefile.am')
-rw-r--r--applets/wncklet/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/applets/wncklet/Makefile.am b/applets/wncklet/Makefile.am
index dc23143f..d9dc7f51 100644
--- a/applets/wncklet/Makefile.am
+++ b/applets/wncklet/Makefile.am
@@ -49,8 +49,8 @@ wnck_applet_CFLAGS = $(AM_CFLAGS)
endif
appletdir = $(datadir)/mate-panel/applets
-applet_in_files = org.mate.panel.Wncklet.mate-panel-applet.in
-applet_DATA = $(applet_in_files:.mate-panel-applet.in=.mate-panel-applet)
+applet_in_files = org.mate.panel.Wncklet.mate-panel-applet.desktop.in
+applet_DATA = $(applet_in_files:.mate-panel-applet.desktop.in=.mate-panel-applet)
$(applet_in_files): $(applet_in_files).in Makefile
$(AM_V_GEN)sed \
@@ -59,7 +59,8 @@ $(applet_in_files): $(applet_in_files).in Makefile
-e "s|\@VERSION\@|$(PACKAGE_VERSION)|" \
$< > $@
-@PANEL_INTLTOOL_MATE_PANEL_APPLET_RULE@
+$(applet_DATA): $(applet_in_files)
+ $(AM_V_GEN) $(MSGFMT) --desktop --keyword Name --keyword Description --template $< -d $(top_srcdir)/po -o $@
if !WNCKLET_INPROCESS
servicedir = $(datadir)/dbus-1/services
@@ -102,16 +103,15 @@ wncklet_gschemas_in = \
endif
gsettings_SCHEMAS = $(wncklet_gschemas_in:.xml.in=.xml)
-@INTLTOOL_XML_NOMERGE_RULE@
@GSETTINGS_RULES@
EXTRA_DIST = \
- org.mate.panel.Wncklet.mate-panel-applet.in.in \
+ org.mate.panel.Wncklet.mate-panel-applet.desktop.in.in \
$(service_in_files) \
$(wncklet_gschemas_in) \
$(ui_FILES) \
wncklet.gresource.xml
-CLEANFILES = $(BUILT_SOURCES) $(applet_DATA) $(applet_DATA).in $(service_DATA) $(gsettings_SCHEMAS)
+CLEANFILES = $(BUILT_SOURCES) $(applet_DATA) $(applet_in_files) $(service_DATA) $(gsettings_SCHEMAS)
-include $(top_srcdir)/git.mk