summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 13 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 45b6158a..f0b45e2a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
-AC_INIT([mate-panel], [1.25.0], [https://github.com/mate-desktop/mate-panel/issues],
- [mate-panel], [http://www.mate-desktop.org])
+AC_INIT([mate-panel], [1.29.0], [https://github.com/mate-desktop/mate-panel/issues],
+ [mate-panel], [https://mate-desktop.org])
AC_CONFIG_HEADERS(config.h)
AM_INIT_AUTOMAKE([1.9 no-dist-gzip dist-xz tar-ustar -Wno-portability check-news])
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
@@ -42,7 +42,7 @@ PANEL_INTLTOOL_MATE_PANEL_APPLET_RULE='%.mate-panel-applet: %.mate-panel-applet.
AC_SUBST([PANEL_INTLTOOL_MATE_PANEL_APPLET_RULE])
AC_ARG_ENABLE(deprecation_flags,
- [AC_HELP_STRING([--enable-deprecation-flags],
+ [AS_HELP_STRING([--enable-deprecation-flags],
[use *_DISABLE_DEPRECATED flags @<:@default=no@:>@])],,
[enable_deprecation_flags=no])
@@ -53,7 +53,7 @@ fi
LT_LIB_M
-LIBMATE_DESKTOP_REQUIRED=1.17.0
+LIBMATE_DESKTOP_REQUIRED=1.28.2
GDK_PIXBUF_REQUIRED=2.26.0
PANGO_REQUIRED=1.15.4
GLIB_REQUIRED=2.50.0
@@ -115,7 +115,7 @@ PANEL_INPROCESS_NONE=
PANEL_INPROCESS_ALL=
PANEL_INPROCESS_APPLETS=
AC_ARG_WITH(in-process-applets,
- AC_HELP_STRING([--with-in-process-applets=APPLETS],
+ AS_HELP_STRING([--with-in-process-applets=APPLETS],
[comma-separated list of applets to compile in-process (possible values: none, clock, fish, notification-area, wncklet, all) @<:@default=none@:>@]),
[for i in `echo $withval | tr , ' '`; do
if test $i = "none"; then
@@ -178,14 +178,14 @@ AC_STRUCT_DIRENT_D_TYPE
# $enable_x11 and $enable_wayland will be set to "yes", "no" or "auto"
AC_ARG_ENABLE(x11,
- [AC_HELP_STRING([--enable-x11],
+ [AS_HELP_STRING([--enable-x11],
[Explicitly enable or disable X11 support
(default is to enable only if X development libraries are detected)])],
[enable_x11=$enableval],
[enable_x11=auto])
AC_ARG_ENABLE(wayland,
- [AC_HELP_STRING([--enable-wayland],
+ [AS_HELP_STRING([--enable-wayland],
[Explicitly enable or disable Wayland support
(default is to enable only if Wayland client development library is detected)])],
[enable_wayland=$enableval],
@@ -194,7 +194,7 @@ AC_ARG_ENABLE(wayland,
# Check if we have gtk-layer-shell installed, and thus should build with Wayland support
have_wayland=no
if test "x$enable_wayland" != "xno"; then
- PKG_CHECK_MODULES(GTK_LAYER_SHELL, gtk-layer-shell-0, have_wayland=yes, [
+ PKG_CHECK_MODULES(WAYLAND, gtk-layer-shell-0 wayland-client, have_wayland=yes, [
if test "x$enable_wayland" = "xyes"; then
AC_MSG_ERROR([Wayland enabled but GTK Layer Shell library not found])
fi
@@ -207,13 +207,13 @@ if test "x$have_wayland" = "xyes"; then
AC_DEFINE(HAVE_WAYLAND, 1, [Have the Wayland development library])
fi
-AC_SUBST(GTK_LAYER_SHELL_CFLAGS)
-AC_SUBST(GTK_LAYER_SHELL_LIBS)
+AC_SUBST(WAYLAND_CFLAGS)
+AC_SUBST(WAYLAND_LIBS)
# Check if we have the X development libraries
have_x11=no
if test "x$enable_x11" != "xno"; then
- PKG_CHECK_MODULES(X, x11 xau, have_x11=yes, [
+ PKG_CHECK_MODULES(X, x11, have_x11=yes, [
if test "x$enable_x11" = "xyes"; then
AC_MSG_ERROR([X development libraries not found])
fi
@@ -293,7 +293,7 @@ if test "x$enable_rebuilds" = "xyes" && \
fi
AC_SUBST(REBUILD)
-AC_OUTPUT([
+AC_CONFIG_FILES([
Makefile
data/Makefile
data/theme/Makefile
@@ -343,6 +343,7 @@ help/mate-clock/Makefile
help/mate-fish/Makefile
man/Makefile
])
+AC_OUTPUT
if echo foo | xgettext --from-code=UTF-8 -LC -o - - 2>/dev/null ; then
:;