summaryrefslogtreecommitdiff
path: root/mate-panel/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mate-panel/Makefile.am')
-rw-r--r--mate-panel/Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/mate-panel/Makefile.am b/mate-panel/Makefile.am
index 1a2a8ee3..f2f04d27 100644
--- a/mate-panel/Makefile.am
+++ b/mate-panel/Makefile.am
@@ -72,7 +72,6 @@ panel_sources += \
panel-xutils.c \
panel-force-quit.c \
panel-action-protocol.c \
- panel-background-monitor.c \
panel-struts.c
endif
@@ -133,7 +132,6 @@ panel_sources += \
panel-xutils.h \
panel-force-quit.h \
panel-action-protocol.h \
- panel-background-monitor.h \
panel-struts.h
endif
@@ -160,8 +158,7 @@ mate_panel_LDADD = \
$(DCONF_LIBS) \
$(XRANDR_LIBS) \
$(X_LIBS) \
- $(WAYLAND_LIBS) \
- -lm
+ $(WAYLAND_LIBS)
if ENABLE_WAYLAND
mate_panel_LDADD += \
@@ -173,6 +170,8 @@ mate_panel_LDFLAGS = -export-dynamic
mate_desktop_item_edit_SOURCES = \
mate-desktop-item-edit.c \
panel-ditem-editor.c \
+ panel-resources.c \
+ panel-resources.h \
panel-marshal.c \
panel-util.c
@@ -191,6 +190,8 @@ mate_desktop_item_edit_LDADD += \
-lX11
endif
+mate_desktop_item_edit_LDFLAGS = -export-dynamic
+
mate_panel_test_applets_SOURCES = \
$(panel_test_applets_BUILT_SOURCES) \
panel-modules.c \
@@ -269,8 +270,9 @@ BUILT_SOURCES = \
$(mate_panel_BUILT_SOURCES) \
$(panel_test_applets_BUILT_SOURCES)
-ui_FILES = \
- panel-properties-dialog.ui \
+ui_FILES = \
+ panel-ditem-editor-dialog.ui \
+ panel-properties-dialog.ui \
panel-run-dialog.ui
panel-resources.c: panel.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir) --generate-dependencies $(srcdir)/panel.gresource.xml)