summaryrefslogtreecommitdiff
path: root/mate-panel/libegg/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mate-panel/libegg/Makefile.am')
-rw-r--r--mate-panel/libegg/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/mate-panel/libegg/Makefile.am b/mate-panel/libegg/Makefile.am
new file mode 100644
index 00000000..c50c1fa0
--- /dev/null
+++ b/mate-panel/libegg/Makefile.am
@@ -0,0 +1,25 @@
+platform_defines = -DEGG_SM_CLIENT_BACKEND_XSMP
+platform_sources = eggsmclient-xsmp.c
+
+noinst_LTLIBRARIES = libegg.la
+
+AM_CPPFLAGS = \
+ $(EGG_SMCLIENT_CFLAGS) \
+ -DG_LOG_DOMAIN=\""EggSMClient"\"\
+ $(platform_defines) \
+ $(DISABLE_DEPRECATED_CFLAGS)
+
+AM_CFLAGS = $(WARN_CFLAGS)
+
+libegg_la_SOURCES = \
+ eggdesktopfile.c \
+ eggdesktopfile.h \
+ eggsmclient.c \
+ eggsmclient.h \
+ eggsmclient-private.h \
+ $(platform_sources)
+
+libegg_la_LIBADD = \
+ $(EGG_SMCLIENT_LIBS)
+
+-include $(top_srcdir)/git.mk