summaryrefslogtreecommitdiff
path: root/mate-panel/libpanel-util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mate-panel/libpanel-util/Makefile.am')
-rw-r--r--mate-panel/libpanel-util/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/mate-panel/libpanel-util/Makefile.am b/mate-panel/libpanel-util/Makefile.am
new file mode 100644
index 00000000..377e26e5
--- /dev/null
+++ b/mate-panel/libpanel-util/Makefile.am
@@ -0,0 +1,39 @@
+noinst_LTLIBRARIES = libpanel-util.la
+
+AM_CPPFLAGS = \
+ $(PANEL_CFLAGS) \
+ -I. \
+ -I$(srcdir) \
+ -I$(top_builddir)/mate-panel/libpanel-util \
+ -DDATADIR=\""$(datadir)"\" \
+ $(DISABLE_DEPRECATED_CFLAGS)
+
+AM_CFLAGS = $(WARN_CFLAGS)
+
+libpanel_util_la_SOURCES = \
+ panel-cleanup.c \
+ panel-cleanup.h \
+ panel-dbus-service.c \
+ panel-dbus-service.h \
+ panel-error.c \
+ panel-error.h \
+ panel-glib.c \
+ panel-glib.h \
+ panel-gtk.c \
+ panel-gtk.h \
+ panel-icon-chooser.c \
+ panel-icon-chooser.h \
+ panel-keyfile.c \
+ panel-keyfile.h \
+ panel-launch.c \
+ panel-launch.h \
+ panel-list.c \
+ panel-list.h \
+ panel-session-manager.c \
+ panel-session-manager.h \
+ panel-show.c \
+ panel-show.h \
+ panel-xdg.c \
+ panel-xdg.h
+
+-include $(top_srcdir)/git.mk