summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorraveit65 <[email protected]>2016-04-06 11:53:36 +0200
committerraveit65 <[email protected]>2016-04-06 11:53:36 +0200
commitd86fdb25aa6f628defed935ae4249406a5ed32a7 (patch)
treec972d91a2f508f5f7d039242206f88f0e7552be0 /Makefile.am
parent8b53edaecf1fa6d0ca73d11dc238cc0d06b54df9 (diff)
downloadmate-screensaver-d86fdb25aa6f628defed935ae4249406a5ed32a7.tar.bz2
mate-screensaver-d86fdb25aa6f628defed935ae4249406a5ed32a7.tar.xz
Add Changelog generation
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1a38c9b..c25ecff 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -56,3 +56,13 @@ MAINTAINERCLEANFILES = \
acinclude.m4 \
$(NULL)
+# Build ChangeLog from GIT history
+ChangeLog:
+ $(AM_V_GEN) if test -d $(top_srcdir)/.git; then \
+ GIT_DIR="$(top_srcdir)/.git" git log --stat > $@; \
+ fi
+
+dist: ChangeLog
+
+.PHONY: ChangeLog
+