summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2012-11-12 14:33:34 +0100
committerStefano Karapetsas <[email protected]>2012-11-12 14:33:34 +0100
commit49b028e85839da7006b4857cf323a7cbee91316c (patch)
tree5bff18351d439b781f10054dba7a46b8aef308f5 /configure.ac
parent77ac5c607d0f0562aad4ab9573c4b85003216c0c (diff)
downloadmate-screensaver-49b028e85839da7006b4857cf323a7cbee91316c.tar.bz2
mate-screensaver-49b028e85839da7006b4857cf323a7cbee91316c.tar.xz
add support for systemd-logind
http://git.gnome.org/browse/gnome-screensaver/commit/?id=6bb98e9acb9391d1aec8f7dcb44ef7d16b3dcb91 https://bugzilla.gnome.org/show_bug.cgi?id=669787
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac40
1 files changed, 39 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f70ad46..ace76f9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -485,7 +485,7 @@ fi
#
if test "$ac_macosx" = yes; then
if test "$enable_locking" = yes; then
- AC_MSG_RESULT(locking disabled: it doesn't work on MacOS X)
+ AC_MSG_RESULT(locking disabled: it doesnt work on MacOS X)
enable_locking=no
AC_DEFINE(NO_LOCKING, 1, [Define if screen locking support is disabled])
fi
@@ -893,6 +893,42 @@ fi
AC_SUBST(AUTH_SCHEME)
dnl ---------------------------------------------------------------------------
+dnl ConsoleKit
+dnl ---------------------------------------------------------------------------
+
+AC_ARG_WITH(console-kit,
+ AS_HELP_STRING([--with-console-kit],
+ [Add ConsoleKit support]),,
+ with_console_kit=auto)
+
+use_console_kit=no
+if test "x$with_console_kit" != "xno" ; then
+ use_console_kit=yes
+ AC_DEFINE(WITH_CONSOLE_KIT, 1, [ConsoleKit support])
+fi
+AM_CONDITIONAL(WITH_CONSOLE_KIT, test x$use_console_kit = xyes)
+AC_SUBST(WITH_CONSOLE_KIT)
+
+dnl ---------------------------------------------------------------------------
+dnl systemd
+dnl ---------------------------------------------------------------------------
+
+AC_ARG_WITH(systemd,
+ AS_HELP_STRING([--with-systemd],
+ [Add systemd support]),,
+ with_systemd=auto)
+
+use_systemd=no
+if test "x$with_systemd" != "xno" ; then
+ use_systemd=yes
+ AC_DEFINE(WITH_SYSTEMD, 1, [systemd support])
+
+ PKG_CHECK_MODULES(SYSTEMD, libsystemd-login libsystemd-daemon)
+fi
+AM_CONDITIONAL(WITH_SYSTEMD, test x$use_systemd = xyes)
+AC_SUBST(WITH_SYSTEMD)
+
+dnl ---------------------------------------------------------------------------
dnl libmatekbd
dnl ---------------------------------------------------------------------------
@@ -1107,6 +1143,8 @@ echo "
Screen locking enabled: ${enable_locking}
Show keyboard indicator: ${with_kbd_layout_indicator}
+ systemd support: ${use_systemd}
+ ConsoleKit support: ${use_console_kit}
libmatenotify support: ${have_libmatenotify}
PAM support: ${have_pam}
Have shadow passwords: ${have_shadow}