summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPaul Wolneykien <[email protected]>2021-10-15 17:29:51 +0300
committerGitHub <[email protected]>2021-10-15 16:29:51 +0200
commited6e6065bf0e85b64317b5a34b9f7a36a0c839a6 (patch)
tree9327a81eb82146d7d43a5ec237040b12e2487de5 /src/Makefile.am
parenta2a282631d9ad88cf5e64f2379c5beb5ab3fab25 (diff)
downloadmate-screensaver-ed6e6065bf0e85b64317b5a34b9f7a36a0c839a6.tar.bz2
mate-screensaver-ed6e6065bf0e85b64317b5a34b9f7a36a0c839a6.tar.xz
Prompt-driven auth. helper
By the term "prompt-driven" I mean two-way conversation between the screensaver dialog and the PAM stack. As you probably know, PAM works by conversation with a dialog program asking the user to enter something in answer to each message it sends. In the most conventional case, the only question is "Password:" and the password is the only data the user enters. But in general, the number of questions and messages are not limited to that. The previous support of PAM helper (gs-auth-helper.c) was written and worked for the mentioned "only password" authentication scheme. For other schemes it wasn't enough. New implementation fixes that limitation. Same as the previous version of gs-auth-helper.c, the new version uses pipe interface for interprocess communication and synchronization. However, unlike the previous version, new version uses two pipes instead of a single pipe: the first one is used to transfer prompt text from PAM via the helper to the screensaver dialog, and the second one is used to transfer the user input from the dialog to helper (and then the helper replies with it back to PAM). Having that bidirectional prompt/reply channel it is possible to make as many prompt/reply passes as required by PAM. The present helper program (see the helper/ dir) is based on the helper written by [email protected], which is in turn loosely based on unix_chkpwd by Andrew Morgan. All new code is untabified under the assumption the tab width is 8. Signed-off-by: Paul Wolneykien <[email protected]>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f26612b..244b653 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -3,7 +3,7 @@ AUTOMAKE_OPTIONS = 1.7
NULL =
-saverdir = $(libexecdir)/mate-screensaver
+saverdir = $(pkglibexecdir)
themesdir = $(pkgdatadir)/themes
AM_CPPFLAGS = \
@@ -21,6 +21,7 @@ AM_CPPFLAGS = \
-DDATADIR=\""$(datadir)"\" \
-DSYSCONFDIR=\""$(sysconfdir)"\" \
-DMATELOCALEDIR=\""$(datadir)/locale"\" \
+ -DPKGLIBEXECDIR=\""$(pkglibexecdir)"\" \
-DSAVERDIR=\""$(saverdir)"\" \
-DTHEMESDIR=\""$(themesdir)"\" \
-DGTKBUILDERDIR=\"$(pkgdatadir)\" \
@@ -69,6 +70,7 @@ mate_screensaver_command_LDADD = \
AUTH_SOURCES = \
gs-auth.h \
+ gs-auth-pam.h \
gs-auth-@[email protected] \
$(NULL)
@@ -99,6 +101,11 @@ test_passwd_LDADD = \
$(AUTH_LIBS) \
$(NULL)
+if HAVE_PASSWD_HELPER
+test_passwd_LDADD += \
+ ../helper/libhelper-proto.a
+endif
+
test_watcher_SOURCES = \
test-watcher.c \
gs-watcher.h \
@@ -161,6 +168,13 @@ mate_screensaver_dialog_LDADD = \
$(LIBNOTIFY_LIBS) \
$(NULL)
+if HAVE_PASSWD_HELPER
+mate_screensaver_dialog_LDADD += \
+ ../helper/libhelper-proto.a
+../helper/libhelper-proto.a:
+ $(MAKE) -C ../helper
+endif
+
BUILT_SOURCES = \
gs-marshal.c \
gs-marshal.h \