summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac116
1 files changed, 66 insertions, 50 deletions
diff --git a/configure.ac b/configure.ac
index 65325cd..ee5c2ba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@ dnl -*- mode: m4 -*-
AC_PREREQ(2.60)
AC_INIT([mate-screensaver],
- [1.26.0],
+ [1.28.0],
[https://mate-desktop.org/])
AC_CONFIG_SRCDIR(src/mate-screensaver.c)
@@ -165,7 +165,7 @@ dnl ---------------------------------------------------------------------------
dnl - Where should we put documentation ?
dnl ---------------------------------------------------------------------------
AC_ARG_WITH(doc-dir,
- [AC_HELP_STRING([--with-doc-dir=<dir>],
+ [AS_HELP_STRING([--with-doc-dir=<dir>],
[directory to install documentation])])
if ! test -z "$with_doc_dir"; then
DOCDIR="$with_doc_dir/mate-screensaver-$VERSION"
@@ -449,7 +449,7 @@ fi
# Check whether to use a xscreensaver hacks configuration directory
AC_MSG_CHECKING([whether to use xscreensaver hacks configuration])
-AC_ARG_WITH(xscreensaverdir, AC_HELP_STRING([--with-xscreensaverdir=dir], [Use xscreensaver hack configs found in directory],))
+AC_ARG_WITH(xscreensaverdir, AS_HELP_STRING([--with-xscreensaverdir=dir], [Use xscreensaver hack configs found in directory],))
xscreensaverdir=
if test "x$with_xscreensaverdir" = "xyes"; then
if test -d /usr/share/xscreensaver/config; then
@@ -471,7 +471,7 @@ else
fi
# Path to xscreensaver hack executables
-AC_ARG_WITH(xscreensaverhackdir, AC_HELP_STRING([--with-xscreensaverhackdir=dir], [Look for xscreensaver hack executables in directory],))
+AC_ARG_WITH(xscreensaverhackdir, AS_HELP_STRING([--with-xscreensaverhackdir=dir], [Look for xscreensaver hack executables in directory],))
AC_MSG_CHECKING([for location of xscreensaver hack executables])
xscreensaverhackdir=
if test "x$with_xscreensaverhackdir" = "xyes" -o "x$with_xscreensaverhackdir" = "x"; then
@@ -566,7 +566,7 @@ dnl - Check for PAM
dnl ---------------------------------------------------------------------------
have_pam=no
-AC_ARG_ENABLE(pam, AC_HELP_STRING([--enable-pam],
+AC_ARG_ENABLE(pam, AS_HELP_STRING([--enable-pam],
[Enable PAM support @<:@default=auto@:>@],
),,enable_pam=auto)
@@ -816,30 +816,29 @@ fi
# all in xscreensaver itself; the external program just does auth.)
have_passwd_helper=no
-with_passwd_helper_req=unspecified
+builtin_helper=no
AC_ARG_WITH(passwd-helper,
[ --with-passwd-helper Include support for an external password
verification helper program.],
- [with_passwd_helper="$withval"; with_passwd_helper_req="$withval"],[with_passwd_helper=no])
+ [with_passwd_helper="$withval"],[with_passwd_helper=no])
# no HANDLE_X_PATH_ARG for this one
if test "$enable_locking" = no ; then
- with_passwd_helper_req=no
with_passwd_helper=no
+ builtin_helper=no
fi
case "$with_passwd_helper" in
""|no) : ;;
/*)
AC_DEFINE_UNQUOTED(PASSWD_HELPER_PROGRAM, "$with_passwd_helper", [Full pathname of password helper application])
+ builtin_helper=no
have_passwd_helper=yes;;
*)
echo "error: --with-passwd-helper needs full pathname of helper (not '$with_passwd_helper')." >&2
exit 1
esac
-AM_CONDITIONAL(HAVE_PASSWD_HELPER, test x$have_passwd_helper = xyes)
-AC_SUBST(HAVE_PASSWD_HELPER)
if test "$need_setuid" = yes -a "$have_pam" != yes ; then
NEED_SETUID=yes
@@ -863,7 +862,9 @@ if test x$enable_authentication_scheme = xpam -a x$have_pam = xno ; then
AC_MSG_ERROR(PAM support requested but not available)
fi
if test x$enable_authentication_scheme = xhelper -a x$have_passwd_helper = xno ; then
- AC_MSG_ERROR(Password helper support requested but not available)
+ builtin_helper=yes
+ have_passwd_helper=yes
+ AC_DEFINE_UNQUOTED(PASSWD_HELPER_PROGRAM, [PKGLIBEXECDIR "/mate-screensaver-pam-helper"], [Full pathname of password helper application])
fi
if test x$enable_authentication_scheme = xbsdauth -a x$have_bsdauth = xno ; then
AC_MSG_ERROR(bsd_auth(3) support requested but not available)
@@ -892,6 +893,9 @@ else
fi
AC_SUBST(AUTH_SCHEME)
+AM_CONDITIONAL(HAVE_PASSWD_HELPER, test x$have_passwd_helper = xyes)
+AM_CONDITIONAL(BUILTIN_HELPER, test x$builtin_helper = xyes)
+AC_SUBST(HAVE_PASSWD_HELPER)
dnl ---------------------------------------------------------------------------
dnl ConsoleKit
@@ -1001,6 +1005,14 @@ if test "x$have_libnotify" = "xyes"; then
fi
dnl ---------------------------------------------------------------------------
+dnl glib headers for pam-helper
+dnl ---------------------------------------------------------------------------
+
+PKG_CHECK_MODULES(PAM_HELPER,
+ glib-2.0 >= $GLIB_REQUIRED_VERSION)
+AC_SUBST(PAM_HELPER_CFLAGS)
+
+dnl ---------------------------------------------------------------------------
dnl Finish
dnl ---------------------------------------------------------------------------
@@ -1103,7 +1115,7 @@ AC_SUBST(themesdir)
# Files
-AC_OUTPUT([
+AC_CONFIG_FILES([
Makefile
po/Makefile.in
src/Makefile
@@ -1117,53 +1129,57 @@ data/images/cosmos/Makefile
savers/Makefile
doc/Makefile
doc/mate-screensaver.xml
+helper/Makefile
])
+AC_OUTPUT
echo "
- mate-screensaver $VERSION
- ========================
-
- prefix: ${prefix}
- exec_prefix: ${exec_prefix}
- libdir: ${EXPANDED_LIBDIR}
- bindir: ${EXPANDED_BINDIR}
- sysconfdir: ${EXPANDED_SYSCONFDIR}
- localstatedir: ${EXPANDED_LOCALSTATEDIR}
- datadir: ${EXPANDED_DATADIR}
- PAM prefix: ${PAM_PREFIX}
- source code location: ${srcdir}
- compiler: ${CC}
- cflags: ${CFLAGS}
- Warning flags: ${WARN_CFLAGS}
- Base libs: ${MATE_SCREENSAVER_LIBS}
- Extension libs: ${SAVER_LIBS}
- Maintainer mode: ${USE_MAINTAINER_MODE}
- Docs enabled: ${enable_docbook_docs}
-
- GL: ${have_libgl}
-
- Screen locking enabled: ${enable_locking}
- Show keyboard indicator: ${with_kbd_layout_indicator}
- systemd support: ${use_systemd}
- elogind support: ${use_elogind}
- ConsoleKit support: ${use_console_kit}
- libnotify support: ${have_libnotify}
- PAM support: ${have_pam}
- bsd_auth(3) support: ${have_bsdauth}
- Have shadow passwords: ${have_shadow}
- Have adjunct shadow: ${have_shadow_adjunct}
- Have enhanced shadow: ${have_shadow_enhanced}
- Have HPUX shadow: ${have_shadow_hpux}
- Have password helper: ${have_passwd_helper}
- Authentication scheme: ${AUTH_SCHEME}"
+Configure summary:
+
+ ${PACKAGE_STRING}
+ `echo $PACKAGE_STRING | sed "s/./=/g"`
+
+ prefix .......................: ${prefix}
+ exec_prefix ..................: ${exec_prefix}
+ libdir .......................: ${EXPANDED_LIBDIR}
+ bindir .......................: ${EXPANDED_BINDIR}
+ sysconfdir ...................: ${EXPANDED_SYSCONFDIR}
+ localstatedir ................: ${EXPANDED_LOCALSTATEDIR}
+ datadir ......................: ${EXPANDED_DATADIR}
+ PAM prefix ...................: ${PAM_PREFIX}
+ source code location .........: ${srcdir}
+ compiler .....................: ${CC}
+ cflags .......................: ${CFLAGS}
+ Warning flags ................: ${WARN_CFLAGS}
+ Base libs ....................: ${MATE_SCREENSAVER_LIBS}
+ Extension libs ...............: ${SAVER_LIBS}
+ Maintainer mode ..............: ${USE_MAINTAINER_MODE}
+ Docs enabled .................: ${enable_docbook_docs}
+
+ GL ...........................: ${have_libgl}
+
+ Screen locking enabled .......: ${enable_locking}
+ Show keyboard indicator ......: ${with_kbd_layout_indicator}
+ systemd support ..............: ${use_systemd}
+ elogind support ..............: ${use_elogind}
+ ConsoleKit support ...........: ${use_console_kit}
+ libnotify support ............: ${have_libnotify}
+ PAM support ..................: ${have_pam}
+ bsd_auth(3) support ..........: ${have_bsdauth}
+ Have shadow passwords ........: ${have_shadow}
+ Have adjunct shadow ..........: ${have_shadow_adjunct}
+ Have enhanced shadow .........: ${have_shadow_enhanced}
+ Have HPUX shadow .............: ${have_shadow_hpux}
+ Have password helper .........: ${have_passwd_helper}
+ Authentication scheme ........: ${AUTH_SCHEME}"
if test "x$need_setuid" = "xyes" -a "x$have_pam" != "xyes" ; then
echo \
-" Need setuid dialog: yes
+" Need setuid dialog ...........: yes
"
else
echo \
-" Need setuid dialog: no
+" Need setuid dialog ...........: no
"
fi