summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..a8851b7
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,27 @@
+NULL =
+
+SPEC_XML_FILES = \
+ mate-screensaver.xml \
+ dbus-interface.xml \
+ $(NULL)
+
+if DOCBOOK_DOCS_ENABLED
+
+htmldocdir = $(DOCDIR)/spec
+htmldoc_DATA = mate-screensaver.html
+
+mate-screensaver.html : dbus-interface.xml
+ $(XMLTO) html-nochunks -m config.xsl mate-screensaver.xml
+
+endif # DOCBOOK_DOCS_ENABLED
+
+EXTRA_DIST = \
+ mate-screensaver.xml.in \
+ config.xsl \
+ docbook.css \
+ $(SPEC_XML_FILES)
+ $(NULL)
+
+clean-local:
+ rm -f *~
+ rm -f mate-screensaver.html