summaryrefslogtreecommitdiff
path: root/savers/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'savers/Makefile.am')
-rw-r--r--savers/Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/savers/Makefile.am b/savers/Makefile.am
index 4f590cf..267a44a 100644
--- a/savers/Makefile.am
+++ b/savers/Makefile.am
@@ -23,17 +23,15 @@ DESKTOP_IN_IN_FILES = \
$(NULL)
cosmos-slideshow.desktop.in: cosmos-slideshow.desktop.in.in Makefile
- $(edit) $< >$@
+ @$(edit) $< >$@
footlogo-floaters.desktop.in: footlogo-floaters.desktop.in.in Makefile
- $(edit) $< >$@
+ @$(edit) $< >$@
gnomelogo-floaters.desktop.in: gnomelogo-floaters.desktop.in.in Makefile
- $(edit) $< >$@
+ @$(edit) $< >$@
personal-slideshow.desktop.in: personal-slideshow.desktop.in.in Makefile
- $(edit) $< >$@
+ @$(edit) $< >$@
popsquares.desktop.in: popsquares.desktop.in.in Makefile
- $(edit) $< >$@
-
-@INTLTOOL_DESKTOP_RULE@
+ @$(edit) $< >$@
edit = sed \
-e 's|@SLIDESHOW_COSMOS_DIR[@]|$(SLIDESHOW_COSMOS_DIR)|g' \
@@ -41,6 +39,9 @@ edit = sed \
-e 's|@FLOATERS_FOOT_GNOME_LOGO_IMAGE[@]|$(FLOATERS_FOOT_GNOME_LOGO_IMAGE)|g' \
-e 's|@SAVERDIR[@]|$(privlibexecdir)|g'
+%.desktop: %.desktop.in
+ $(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
+
themesdir = $(datadir)/applications/screensavers
themes_in_files = \
cosmos-slideshow.desktop.in \