summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8864c38..59e3fe4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -31,4 +31,14 @@ MAINTAINERCLEANFILES = \
DISTCHECK_CONFIGURE_FLAGS = --disable-upower
+# Build ChangeLog from GIT history
+ChangeLog:
+ $(AM_V_GEN) if test -d $(top_srcdir)/.git; then \
+ GIT_DIR="$(top_srcdir)/.git" git log --stat > $@; \
+ fi
+
+dist: ChangeLog
+
+.PHONY: ChangeLog
+
-include $(top_srcdir)/git.mk