summaryrefslogtreecommitdiff
path: root/capplet/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'capplet/Makefile.am')
-rw-r--r--capplet/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/capplet/Makefile.am b/capplet/Makefile.am
new file mode 100644
index 0000000..cab50d1
--- /dev/null
+++ b/capplet/Makefile.am
@@ -0,0 +1,33 @@
+bin_PROGRAMS = mate-session-properties
+
+AM_CPPFLAGS = \
+ $(SESSION_PROPERTIES_CFLAGS) \
+ $(MATECONF_CFLAGS) \
+ -I$(top_srcdir)/egg \
+ -I$(top_srcdir)/mate-session \
+ -DLOCALE_DIR=\""$(datadir)/locale"\" \
+ -DGTKBUILDER_DIR=\""$(pkgdatadir)"\" \
+ $(DISABLE_DEPRECATED_CFLAGS)
+
+AM_CFLAGS = $(WARN_CFLAGS)
+
+mate_session_properties_SOURCES = \
+ main.c \
+ gsm-properties-dialog.h \
+ gsm-properties-dialog.c \
+ gsm-app-dialog.h \
+ gsm-app-dialog.c \
+ gsp-app.h \
+ gsp-app.c \
+ gsp-app-manager.h \
+ gsp-app-manager.c \
+ gsp-keyfile.h \
+ gsp-keyfile.c
+
+mate_session_properties_LDADD = \
+ $(SESSION_PROPERTIES_LIBS) \
+ $(top_builddir)/egg/libeggdesktopfile.la \
+ $(top_builddir)/mate-session/libgsmutil.la \
+ $(MATECONF_LIBS)
+
+-include $(top_srcdir)/git.mk