summaryrefslogtreecommitdiff
path: root/data/icons/48x48/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/icons/48x48/Makefile.am')
-rw-r--r--data/icons/48x48/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/data/icons/48x48/Makefile.am b/data/icons/48x48/Makefile.am
new file mode 100644
index 0000000..36cffbd
--- /dev/null
+++ b/data/icons/48x48/Makefile.am
@@ -0,0 +1,21 @@
+size = 48x48
+
+iconsdir = $(datadir)/icons/hicolor/$(size)/apps
+
+icons_DATA = mate-session-properties.png
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
+install-data-hook:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
+
+EXTRA_DIST = \
+ $(icons_DATA)
+
+-include $(top_srcdir)/git.mk