summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZhang Xianwei <[email protected]>2018-10-18 17:09:38 +0800
committerraveit65 <[email protected]>2018-10-24 18:19:17 +0200
commit2b528edce044642edcd388b851f52012b7e09e38 (patch)
treea1fc84470e773a5ef74e4a4aa481cb1c17bacc6c /configure.ac
parent765208efe3772d5aebf1680c4c5fac87a9b33136 (diff)
downloadmate-settings-daemon-2b528edce044642edcd388b851f52012b7e09e38.tar.bz2
mate-settings-daemon-2b528edce044642edcd388b851f52012b7e09e38.tar.xz
rfkill: Add RFKill support plugin on Linux systems
from https://github.com/GNOME/gnome-settings-daemon/commit/444af32e343a79ca3db0f957bf73687a0f0df9ec Signed-off-by: Zhang Xianwei <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 63d1c62..b3b77c1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -356,6 +356,21 @@ AC_SUBST(POLKIT_CFLAGS)
AC_SUBST(POLKIT_LIBS)
# ---------------------------------------------------------------------------
+# Rfkill
+# ---------------------------------------------------------------------------
+
+AC_ARG_ENABLE(rfkill,
+ AS_HELP_STRING([--disable-rfkill], [disable rfkill support (default: enabled)]),,
+ enable_rfkill=yes, enabled_rfkill=no)
+
+if test x"$enable_rfkill" != x"no" ; then
+ AC_CHECK_HEADERS([linux/rfkill.h],,
+ AC_MSG_ERROR([RFKill headers not found but rfkill support requested]))
+fi
+
+AM_CONDITIONAL(BUILD_RFKILL, [test x"$enable_rfkill" = x"yes"])
+
+# ---------------------------------------------------------------------------
# Enable Profiling
# ---------------------------------------------------------------------------
AC_ARG_ENABLE(profiling,
@@ -454,6 +469,7 @@ plugins/keyboard/Makefile
plugins/media-keys/Makefile
plugins/mpris/Makefile
plugins/mouse/Makefile
+plugins/rfkill/Makefile
plugins/smartcard/Makefile
plugins/sound/Makefile
plugins/typing-break/Makefile
@@ -480,6 +496,7 @@ data/org.mate.SettingsDaemon.plugins.keyboard.gschema.xml
data/org.mate.SettingsDaemon.plugins.media-keys.gschema.xml
data/org.mate.SettingsDaemon.plugins.mpris.gschema.xml
data/org.mate.SettingsDaemon.plugins.mouse.gschema.xml
+data/org.mate.SettingsDaemon.plugins.rfkill.gschema.xml
data/org.mate.SettingsDaemon.plugins.smartcard.gschema.xml
data/org.mate.SettingsDaemon.plugins.sound.gschema.xml
data/org.mate.SettingsDaemon.plugins.typing-break.gschema.xml
@@ -521,6 +538,7 @@ echo "
Libcanberra support: ${have_libcanberra}
Libmatemixer support: ${have_libmatemixer}
Smartcard support: ${have_smartcard_support}
+ RFKill support: ${enable_rfkill}
${NSS_DATABASE:+\
System nssdb: ${NSS_DATABASE}
}\