summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrbuj <[email protected]>2019-02-22 12:02:30 +0100
committerZenWalker <[email protected]>2019-03-15 20:37:21 +0100
commit449753407d3ecf43e3401363557437984c138941 (patch)
tree9fc9697392d10fce6c36a676e94c7ff16b879ec2 /configure.ac
parent773ef179210ecc4572ba9df1887ba79ac1eb1876 (diff)
downloadmate-terminal-449753407d3ecf43e3401363557437984c138941.tar.bz2
mate-terminal-449753407d3ecf43e3401363557437984c138941.tar.xz
Use gresources for about_DATA, uimanager_DATA & builder_DATA
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5692658..d974787 100644
--- a/configure.ac
+++ b/configure.ac
@@ -72,6 +72,24 @@ AC_SUBST([GLIB_GENMARSHAL])
GLIB_MKENUMS="$($PKG_CONFIG --variable=glib_mkenums glib-2.0)"
AC_SUBST([GLIB_MKENUMS])
+# **********************
+# GLIB_COMPILE_RESOURCES
+# **********************
+AC_ARG_VAR([GLIB_COMPILE_RESOURCES],[glib-compile-resources bin])
+AC_PATH_PROG([GLIB_COMPILE_RESOURCES],[glib-compile-resources],[])
+if test -z "$GLIB_COMPILE_RESOURCES"; then
+ AC_MSG_ERROR([glib-compile-resources not found])
+fi
+
+# *******
+# XMLLINT
+# *******
+AC_ARG_VAR([XMLLINT],[xmllint bin])
+AC_PATH_PROG([XMLLINT],[xmllint],[])
+if test -z "$XMLLINT"; then
+ AC_MSG_ERROR([xmllint not found])
+fi
+
# *****
# S/Key
# *****