summaryrefslogtreecommitdiff
path: root/desktop-themes/Blue-Submarine/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'desktop-themes/Blue-Submarine/Makefile.am')
-rw-r--r--desktop-themes/Blue-Submarine/Makefile.am19
1 files changed, 11 insertions, 8 deletions
diff --git a/desktop-themes/Blue-Submarine/Makefile.am b/desktop-themes/Blue-Submarine/Makefile.am
index e70fee01..1c3e8029 100644
--- a/desktop-themes/Blue-Submarine/Makefile.am
+++ b/desktop-themes/Blue-Submarine/Makefile.am
@@ -1,19 +1,22 @@
-THEME_NAME=Blue-Submarine
-THEME_IN_FILES=index.theme.in
+THEME_NAME = Blue-Submarine
themedir = $(datadir)/themes/$(THEME_NAME)
+theme_in_files = index.theme.in
+theme_DATA = $(theme_in_files:.theme.in=.theme)
-theme_DATA = index.theme
-
-$(theme_DATA): $(THEME_IN_FILES)
+%.theme: %.theme.in
+if USE_NLS
$(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
+else
+ $(AM_V_GEN) cp -f $< $@
+endif
SUBDIRS = \
cinnamon \
- emerald \
+ emerald \
gtk-2.0 \
gtk-3.0 \
metacity-1
-DISTCLEANFILES = index.theme
-EXTRA_DIST = index.theme.in
+CLEANFILES = index.theme
+EXTRA_DIST = $(theme_in_files)