summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorraveit65 <[email protected]>2013-08-21 23:46:40 +0200
committerraveit65 <[email protected]>2013-08-21 23:46:40 +0200
commit6b2d9e48c82b8b73fd2af640fce4c1ba27eb7b50 (patch)
treea2eceb3588f8e75fd7eaa9c109e8f0f31d727ee1 /configure.ac
parent8701e25197a994f544c8b65561f25478dafc0b5b (diff)
downloadmate-user-share-6b2d9e48c82b8b73fd2af640fce4c1ba27eb7b50.tar.bz2
mate-user-share-6b2d9e48c82b8b73fd2af640fce4c1ba27eb7b50.tar.xz
make bluetooth really optional
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 20 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 758d4b3..5b9b489 100644
--- a/configure.ac
+++ b/configure.ac
@@ -50,20 +50,20 @@ fi
AC_SUBST(HTTPD)
-PKG_CHECK_MODULES(USER_SHARE, glib-2.0 >= 2.15.2 gio-2.0 >= 2.26 gdk-x11-2.0 gtk+-2.0 dbus-1 >= 1.1.1 dbus-glib-1 libnotify >= 0.7.0 libcanberra-gtk $DBUS_MODULES)
-AC_SUBST(USER_SHARE_CFLAGS)
-AC_SUBST(USER_SHARE_LIBS)
-
-PKG_CHECK_MODULES(BLUETOOTH, mate-bluetooth-1.0 >= 1.2.0,
- have_bluetooth=true, have_bluetooth=false)
-AC_SUBST(BLUETOOTH_CFLAGS)
-AC_SUBST(BLUETOOTH_LIBS)
-if $have_bluetooth; then
- AC_DEFINE(HAVE_BLUETOOTH, 1, [Set to true if mate-bluetooth support is available])
+BLUETOOTH_PKG="mate-bluetooth-1.0 >= 1.2.0"
+AC_ARG_ENABLE(bluetooth, AS_HELP_STRING([--disable-bluetooth],[compile without bluetooth support]),,enable_bluetooth=yes)
+if test "x$enable_bluetooth" = "xyes"; then
+ PKG_CHECK_MODULES(BLUETOOTH, $BLUETOOTH_PKG)
+ AC_DEFINE(HAVE_BLUETOOTH, 1, [Set to true if mate-bluetooth support is available])
else
- AC_MSG_WARN([Bluetooth support is disabled.])
+ BLUETOOTH_PKG=""
+ AC_MSG_WARN([Bluetooth support is disabled.])
fi
-AM_CONDITIONAL(USE_BLUETOOTH, [test "$have_bluetooth" = "true"])
+AM_CONDITIONAL(USE_BLUETOOTH, [test "$enable_bluetooth" = "yes"])
+
+PKG_CHECK_MODULES(USER_SHARE, glib-2.0 >= 2.15.2 gio-2.0 >= 2.26 gdk-x11-2.0 gtk+-2.0 dbus-1 >= 1.1.1 dbus-glib-1 libnotify >= 0.7.0 libcanberra-gtk $DBUS_MODULES $BLUETOOTH_PKG)
+AC_SUBST(USER_SHARE_CFLAGS)
+AC_SUBST(USER_SHARE_LIBS)
PKG_CHECK_MODULES(USER_SHARE_CONFIG, glib-2.0 >= 2.15.2 gio-2.0 >= 2.25.0 gtk+-2.0 >= 2.12.0 unique-1.0)
AC_SUBST(USER_SHARE_CONFIG_CFLAGS)
@@ -139,7 +139,7 @@ AC_ARG_WITH(cajadir,
[ac_with_cajadir=""])
PKG_CHECK_MODULES(EXTENSION,
- libcaja-extension mate-bluetooth-1.0)
+ libcaja-extension $BLUETOOTH_PKG)
if test "${ac_with_cajadir}" = ""; then
ac_with_cajadir=`pkg-config --variable=extensiondir libcaja-extension`
fi
@@ -208,6 +208,13 @@ man/Makefile
])
AC_OUTPUT
+
+if test "x$enable_bluetooth" = "xyes"; then
+ AC_MSG_NOTICE([** Bluetooth support enabled (ObexPush and ObexFTP)])
+else
+ AC_MSG_NOTICE([ Bluetooth support disabled])
+fi
+
AC_MSG_NOTICE([mate-user-share was configured with the following options:])
AC_MSG_NOTICE([** httpd location: $HTTP])
AC_MSG_NOTICE([** httpd modules path: $MODULES_PATH])