summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2011-12-14 10:13:54 +0100
committerStefano Karapetsas <[email protected]>2011-12-14 10:13:54 +0100
commitef0467789bfc8406b57ba553e4d59f4d6c3f9be8 (patch)
tree09d541636a16cb38448fe6183289ebdc3080c1bf /Makefile.am
downloadmate-utils-ef0467789bfc8406b57ba553e4d59f4d6c3f9be8.tar.bz2
mate-utils-ef0467789bfc8406b57ba553e4d59f4d6c3f9be8.tar.xz
Moved from Mate-Extra repository
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am60
1 files changed, 60 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 00000000..1d402595
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,60 @@
+#
+# FIXME:
+# currently scrollkeeper-update does not seem to
+# remove its database when there is no useful
+# information contained there. Therefore, with
+# "make uninstall" you're left with loads of
+# stuff in /var/scrollkeeper and distcheck
+# fails.
+#
+# http://mail.mate.org/archives/mate-doc-list/2003-May/msg00008.html
+#
+# This overrides the uninstall check so distcheck
+# passes
+#
+# distuninstallcheck_listfiles = find . -type f -print | grep -v 'scrollkeeper' | grep -v 'omf' | grep -v 'figures'
+distuninstallcheck:
+ @:
+
+distcleancheck_listfiles = find . -type f -print | grep -v 'omf\.out' | grep -v 'legal.xml'
+
+ACLOCAL_AMFLAGS = -I m4
+
+SUBDIRS = \
+ m4 \
+ po \
+ libeggsmclient \
+ baobab \
+ mate-dictionary \
+ mate-screenshot \
+ gsearchtool \
+ logview \
+ $(NULL)
+
+EXTRA_DIST = \
+ omf.make \
+ xmldocs.make \
+ mate-doc-utils.make \
+ COPYING.libs \
+ COPYING.docs
+
+DISTCLEANFILES = \
+ gtk-doc.make \
+ mate-doc-utils.make
+
+DISTCHECK_CONFIGURE_FLAGS = --disable-scrollkeeper --enable-gtk-doc
+
+dist-hook:
+ @if test -d "$(srcdir)/.git"; \
+ then \
+ from="git-import"; \
+ echo Creating ChangeLog && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generate by configure. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run git log --stat $$from.. ) > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
+ || ( rm -f ChangeLog.tmp ; \
+ echo Failed to generate ChangeLog >&2 ); \
+ else \
+ echo A git clone is required to generate a ChangeLog >&2; \
+ fi