summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrbuj <[email protected]>2019-12-09 23:05:56 +0100
committerRobert Antoni Buj Gelonch <[email protected]>2019-12-23 08:55:37 +0100
commitd6318fc5174c6e5915ed22c53b17a681850c97c0 (patch)
tree52e0c82b9e6318f70ffb07fac79b0d396970a6f9 /configure.ac
parentb8b0f4f70656476e51c0a645875d07c8c8225626 (diff)
downloadmate-utils-d6318fc5174c6e5915ed22c53b17a681850c97c0.tar.bz2
mate-utils-d6318fc5174c6e5915ed22c53b17a681850c97c0.tar.xz
Use gresources for UI files
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 587f5079..244e217c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -38,6 +38,20 @@ AM_CONDITIONAL([HAVE_INKSCAPE], [test "x$INKSCAPE" != x])
MATE_COMPILE_WARNINGS([yes])
+# GLIB_COMPILE_RESOURCES
+AC_ARG_VAR([GLIB_COMPILE_RESOURCES],[glib-compile-resources bin])
+AC_PATH_PROG([GLIB_COMPILE_RESOURCES],[glib-compile-resources],[])
+if test -z "$GLIB_COMPILE_RESOURCES"; then
+ AC_MSG_ERROR([glib-compile-resources not found])
+fi
+
+# XMLLINT
+AC_ARG_VAR([XMLLINT],[xmllint bin])
+AC_PATH_PROG([XMLLINT],[xmllint],[])
+if test -z "$XMLLINT"; then
+ AC_MSG_ERROR([xmllint not found])
+fi
+
AC_PATH_XTRA
AC_C_CONST