summaryrefslogtreecommitdiff
path: root/logview/data/icons/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2019-03-16 18:22:58 +0100
committerraveit65 <[email protected]>2019-03-25 13:15:05 +0100
commit14cd43685163f3ad3e9a79a5b2cb05e7fb420f91 (patch)
tree55e39e057bd1b686eb020bdf9ff6cb693aac525b /logview/data/icons/Makefile.am
parente46d962c7d048121bf845bbc2eaaac5849d2aefc (diff)
downloadmate-utils-14cd43685163f3ad3e9a79a5b2cb05e7fb420f91.tar.bz2
mate-utils-14cd43685163f3ad3e9a79a5b2cb05e7fb420f91.tar.xz
GEN png icons from svg files
PNG icons are created if they are not present in icon folder. To remove png icons: make -C baobab/pixmaps clean-png-icons make -C logview/data/icons clean-png-icons To build png icons: make -C baobab/pixmaps build-png-icons make -C logview/data/icons build-png-icons This removes baobab/pixmaps/shot.png file, use applets-screenshooter named icon (used in mate-screenshot).
Diffstat (limited to 'logview/data/icons/Makefile.am')
-rw-r--r--logview/data/icons/Makefile.am67
1 files changed, 45 insertions, 22 deletions
diff --git a/logview/data/icons/Makefile.am b/logview/data/icons/Makefile.am
index 20f0da67..7dcf7a2c 100644
--- a/logview/data/icons/Makefile.am
+++ b/logview/data/icons/Makefile.am
@@ -4,15 +4,34 @@ public_icons_themes = \
hicolor \
$(NULL)
+png_icons = \
+ hicolor_apps_16x16_mate-system-log.png \
+ hicolor_apps_22x22_mate-system-log.png \
+ hicolor_apps_32x32_mate-system-log.png \
+ hicolor_apps_48x48_mate-system-log.png \
+ hicolor_apps_256x256_mate-system-log.png \
+ $(NULL)
+
public_icons = \
- hicolor_apps_16x16_mate-system-log.png \
- hicolor_apps_22x22_mate-system-log.png \
- hicolor_apps_32x32_mate-system-log.png \
- hicolor_apps_48x48_mate-system-log.png \
- hicolor_apps_256x256_mate-system-log.png \
+ $(png_icons) \
hicolor_apps_scalable_mate-system-log-symbolic.svg \
$(NULL)
+hicolor_apps_16x16_mate-system-log.png: logview.svg
+ inkscape -z $^ --export-area=303:65:319:81 -w=16 -h=16 -e=$@
+
+hicolor_apps_22x22_mate-system-log.png: logview.svg
+ inkscape -z $^ --export-area=303:101:325:123 -w=22 -h=22 -e=$@
+
+hicolor_apps_32x32_mate-system-log.png: logview.svg
+ inkscape -z $^ --export-area=304:142:336:174 -w=32 -h=32 -e=$@
+
+hicolor_apps_48x48_mate-system-log.png: logview.svg
+ inkscape -z $^ --export-area=296:202:344:250 -w=48 -h=48 -e=$@
+
+hicolor_apps_256x256_mate-system-log.png: logview.svg
+ inkscape -z $^ --export-area=33:11:289:267 -w=256 -h=256 -e=$@
+
noinst_DATA = \
logview.svg \
$(NULL)
@@ -24,21 +43,6 @@ EXTRA_DIST = \
###############################################################################
-gtk_update_icon_cache = gtk-update-icon-cache -f -t
-
-update-icon-cache:
- @-if test -z "$(DESTDIR)"; then \
- echo "Updating Gtk icon cache."; \
- for theme in $(public_icons_themes); do \
- $(gtk_update_icon_cache) $(datadir)/icons/$$theme; \
- done; \
- else \
- echo "*** Icon cache not updated. After (un)install, run this:"; \
- for theme in $(public_icons_themes); do \
- echo "*** $(gtk_update_icon_cache) $(datadir)/icons/$$theme"; \
- done; \
- fi
-
install-icons:
for icon in $(public_icons); do \
THEME=`echo $$icon | cut -d_ -f1`; \
@@ -58,6 +62,25 @@ uninstall-icons:
rm -f $(DESTDIR)$(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT/$$ICONFILE; \
done
-install-data-local: install-icons update-icon-cache
+install-data-local: install-icons
+
+uninstall-local: uninstall-icons
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
+update-icon-cache: $(public_icons)
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
+
+.PHONY: build-png-icons clean-png-icons
+build-png-icons: $(png_icons)
-uninstall-local: uninstall-icons update-icon-cache
+clean-png-icons:
+ rm -f $(png_icons)