summaryrefslogtreecommitdiff
path: root/mate-dictionary/data/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2021-01-31 22:51:13 +0100
committerraveit65 <[email protected]>2021-03-05 20:18:27 +0100
commit768071911a44b7460105a27192ebcc92a9af8dda (patch)
tree6d506362201c6e47da3a7d67d61349a0214d3dba /mate-dictionary/data/Makefile.am
parenta876b88b5b5e16031ea86b49d63b955271a671cb (diff)
downloadmate-utils-768071911a44b7460105a27192ebcc92a9af8dda.tar.bz2
mate-utils-768071911a44b7460105a27192ebcc92a9af8dda.tar.xz
i18n: Do not collect the translation for Icon
Diffstat (limited to 'mate-dictionary/data/Makefile.am')
-rw-r--r--mate-dictionary/data/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/mate-dictionary/data/Makefile.am b/mate-dictionary/data/Makefile.am
index f47069ba..81cfcd35 100644
--- a/mate-dictionary/data/Makefile.am
+++ b/mate-dictionary/data/Makefile.am
@@ -24,6 +24,13 @@ gdictapp_DATA = $(gdictapp_in_files:.desktop.in=.desktop)
$(gdictapp_in_files): $(gdictapp_in_files:.desktop.in=.desktop.in.in)
$(AM_V_GEN)sed -e "s|\@VERSION\@|@VERSION@|" $< > $@
+$(gdictapp_DATA): $(gdictapp_in_files)
+if USE_NLS
+ $(AM_V_GEN) $(MSGFMT) --desktop --keyword= --keyword=Name --keyword=Comment --keyword=Keywords --template $< -d $(top_srcdir)/po -o $@
+else
+ $(AM_V_GEN) cp $< $@
+endif
+
# dictionary sources definitions
dictsourcedir = $(datadir)/mate-dict/sources
dictsource_in_files = \
@@ -32,9 +39,9 @@ dictsource_in_files = \
$(NULL)
dictsource_DATA = $(dictsource_in_files:.desktop.in=.desktop)
-%.desktop: %.desktop.in
+$(dictsource_DATA): $(dictsource_in_files)
if USE_NLS
- $(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
+ $(AM_V_GEN) $(MSGFMT) --desktop --keyword= --keyword=Name --keyword=Description --template $< -d $(top_srcdir)/po -o $@
else
$(AM_V_GEN) cp $< $@
endif