summaryrefslogtreecommitdiff
path: root/mate-dictionary
diff options
context:
space:
mode:
authorKir Kolyshkin <[email protected]>2016-05-16 14:52:28 -0700
committerKir Kolyshkin <[email protected]>2016-05-17 15:27:13 -0700
commit5ab184661ff38baca3ea2709d81932a578654392 (patch)
tree9a214d2a304b5e6ac4fb7c2056f93d9b40be097d /mate-dictionary
parentd093ed148cded78110f5ab5ea4fa7c5e28a1f66e (diff)
downloadmate-utils-5ab184661ff38baca3ea2709d81932a578654392.tar.bz2
mate-utils-5ab184661ff38baca3ea2709d81932a578654392.tar.xz
mate-dict.pc: depend upon proper gtk version
If the package is built against gtk-3.0 (as in ./configure --with-gtk=3.0), mate-dict.pc still wants gtk-2.0 since it's hardcoded it there. This can lead to improper builds of packages using libmatedict (although I can't find any now), as well as improper RPM dependencies, like this: $ rpm -e gtk2-devel error: Failed dependencies: ... pkgconfig(gtk+-2.0) is needed by (installed) mate-utils-devel-1.14.0-1gtk3.fc23.x86_64 Fortunately, the file is already generated, so it's trivial to add a proper substitution. [v2: also add min GTK version required] Signed-off-by: Kir Kolyshkin <[email protected]>
Diffstat (limited to 'mate-dictionary')
-rw-r--r--mate-dictionary/libgdict/mate-dict.pc.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/mate-dictionary/libgdict/mate-dict.pc.in b/mate-dictionary/libgdict/mate-dict.pc.in
index e409a0cb..8168de2d 100644
--- a/mate-dictionary/libgdict/mate-dict.pc.in
+++ b/mate-dictionary/libgdict/mate-dict.pc.in
@@ -5,7 +5,7 @@ [email protected]@
Name: gdict-1.0
Description: MATE Dictionary Protocol client library
-Requires: gtk+-2.0
Libs: -L${libdir} -lmatedict
Cflags: -I${includedir}/mate-dict