summaryrefslogtreecommitdiff
path: root/mate-screenshot/Makefile.am
diff options
context:
space:
mode:
authorinfirit <[email protected]>2014-11-10 00:13:36 +0100
committerinfirit <[email protected]>2014-11-10 00:19:38 +0100
commit62ef06fb0ff90f567367207c4238ed92a965e4b3 (patch)
tree88acd623782f68d1f60b7214eb7986bdd7886913 /mate-screenshot/Makefile.am
parent893054f0fca52de51c39bb920bbfd7bf3fa1e47c (diff)
downloadmate-utils-62ef06fb0ff90f567367207c4238ed92a965e4b3.tar.bz2
mate-utils-62ef06fb0ff90f567367207c4238ed92a965e4b3.tar.xz
appdata: Add autotool bits for appdata
Diffstat (limited to 'mate-screenshot/Makefile.am')
-rw-r--r--mate-screenshot/Makefile.am19
1 files changed, 12 insertions, 7 deletions
diff --git a/mate-screenshot/Makefile.am b/mate-screenshot/Makefile.am
index e8e54cad..1fa3cdc7 100644
--- a/mate-screenshot/Makefile.am
+++ b/mate-screenshot/Makefile.am
@@ -58,12 +58,15 @@ ui_DATA = \
mate-screenshot.ui \
$(NULL)
+@INTLTOOL_XML_RULE@
+appdatadir = $(datadir)/appdata
+appdata_in_files = mate-screenshot.appdata.xml.in
+appdata_DATA = $(appdata_in_files:.xml.in=.xml)
+
gsettingsschema_in_files = org.mate.screenshot.gschema.xml.in
gsettings_SCHEMAS = $(gsettingsschema_in_files:.xml.in=.xml)
.PRECIOUS: $(gsettings_SCHEMAS)
-@INTLTOOL_XML_NOMERGE_RULE@
-
@GSETTINGS_RULES@
convertdir = $(datadir)/MateConf/gsettings
@@ -71,17 +74,19 @@ convert_DATA = mate-screenshot.convert
EXTRA_DIST = \
$(gsettingsschema_in_files) \
+ $(appdata_in_files) \
$(mate_screenshot_in_files) \
$(man_MANS) \
$(ui_DATA) \
- $(convert_DATA) \
+ $(convert_DATA) \
$(NULL)
CLEANFILES = \
- $(BUILT_SOURCES) \
- $(gsettings_SCHEMAS) \
- $(mate_screenshot_DATA) \
- $(sys_DATA)
+ $(BUILT_SOURCES) \
+ $(gsettings_SCHEMAS) \
+ $(mate_screenshot_DATA) \
+ $(sys_DATA) \
+ mate-screenshot.appdata.xml
dist-hook:
cd $(distdir) ; rm -f $(CLEANFILES)