summaryrefslogtreecommitdiff
path: root/mate-screenshot/Makefile.am
diff options
context:
space:
mode:
authorraveit65 <[email protected]>2015-06-16 14:59:46 +0200
committerraveit65 <[email protected]>2015-06-16 16:28:05 +0200
commitc4df12f12d21ea7d4bc0d656bd5f93539c078d93 (patch)
tree3fd0d8e272580cdb97de5dcbf56f64c7bb9369df /mate-screenshot/Makefile.am
parent519aa6b184aa07a2afd09e76d1f36aaa5032b3fa (diff)
downloadmate-utils-c4df12f12d21ea7d4bc0d656bd5f93539c078d93.tar.bz2
mate-utils-c4df12f12d21ea7d4bc0d656bd5f93539c078d93.tar.xz
fixes for gschema translation
taken from: https://github.com/mate-desktop/eom/commit/a2055e1 - bumped required intltool version to 0.50.1 - renamed and corrected gschema xml for proper intltool usage - sorted lines in po/POTFILES.in (as requested in the header)
Diffstat (limited to 'mate-screenshot/Makefile.am')
-rw-r--r--mate-screenshot/Makefile.am18
1 files changed, 7 insertions, 11 deletions
diff --git a/mate-screenshot/Makefile.am b/mate-screenshot/Makefile.am
index 1fa3cdc7..7cce5d0c 100644
--- a/mate-screenshot/Makefile.am
+++ b/mate-screenshot/Makefile.am
@@ -63,30 +63,26 @@ appdatadir = $(datadir)/appdata
appdata_in_files = mate-screenshot.appdata.xml.in
appdata_DATA = $(appdata_in_files:.xml.in=.xml)
-gsettingsschema_in_files = org.mate.screenshot.gschema.xml.in
-gsettings_SCHEMAS = $(gsettingsschema_in_files:.xml.in=.xml)
-.PRECIOUS: $(gsettings_SCHEMAS)
-
+gsettings_SCHEMAS = org.mate.screenshot.gschema.xml
@GSETTINGS_RULES@
convertdir = $(datadir)/MateConf/gsettings
convert_DATA = mate-screenshot.convert
EXTRA_DIST = \
- $(gsettingsschema_in_files) \
$(appdata_in_files) \
- $(mate_screenshot_in_files) \
+ $(mate_screenshot_in_files) \
$(man_MANS) \
$(ui_DATA) \
- $(convert_DATA) \
+ $(convert_DATA) \
$(NULL)
CLEANFILES = \
- $(BUILT_SOURCES) \
- $(gsettings_SCHEMAS) \
- $(mate_screenshot_DATA) \
+ $(BUILT_SOURCES) \
+ $(gsettings_SCHEMAS) \
+ $(mate_screenshot_DATA) \
$(sys_DATA) \
- mate-screenshot.appdata.xml
+ $(appdata_DATA)
dist-hook:
cd $(distdir) ; rm -f $(CLEANFILES)