summaryrefslogtreecommitdiff
path: root/baobab/pixmaps/24x24/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'baobab/pixmaps/24x24/Makefile.am')
-rw-r--r--baobab/pixmaps/24x24/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/baobab/pixmaps/24x24/Makefile.am b/baobab/pixmaps/24x24/Makefile.am
new file mode 100644
index 00000000..73be6d11
--- /dev/null
+++ b/baobab/pixmaps/24x24/Makefile.am
@@ -0,0 +1,29 @@
+NULL =
+
+size = 24x24
+
+iconsdir = $(datadir)/icons/mate/$(size)/apps
+
+icons_DATA = \
+ baobab.png \
+ $(NULL)
+
+icons_SOURCE = \
+ $(NULL)
+
+EXTRA_DIST = \
+ $(icons_DATA) \
+ $(icons_SOURCE)
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
+update-icon-cache:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi