summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorlukefromdc <[email protected]>2016-10-22 23:14:31 -0400
committerlukefromdc <[email protected]>2016-10-22 23:14:31 -0400
commitec529e70c20c4164fe34179fc1956676bd10e665 (patch)
tree4c3ebe494797ee62b16bd5efa05a99408571b90b /src/Makefile.am
parent481d6eeee76b95faec6053280739c6bed1dd23b3 (diff)
downloadcaja-ec529e70c20c4164fe34179fc1956676bd10e665.tar.bz2
caja-ec529e70c20c4164fe34179fc1956676bd10e665.tar.xz
GtkApplication: Notify when ejected volumes safe to unplug
Notify users when an external drive is still writing data on attempt to eject, and again when drive is safe to unmount. Notifications behave as they do in Nemo when ejecting/unmounting a flash drive. Tested with GTK 3.22 and a known slow flash drive. This is in GtkApplication builds only, code is from Nemo. FIXME: build system does not limit libnotify dependency to GtkApplication builds and is rather improvised. Adding libnotify to CORE_MODULES via configure.ac did not work, and using Nemo's changes put -lnotify into CORE rather than ALL libs and that caused build failures on failure to link.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e13f5bc2..5ad77ed4 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -41,6 +41,7 @@ LDADD = \
$(EXIF_LIBS) \
$(EXEMPI_LIBS) \
$(POPT_LIBS) \
+ -lnotify
$(NULL)
dbus_freedesktop_built_sources = \