summaryrefslogtreecommitdiff
path: root/backends/alsa/Makefile.am
diff options
context:
space:
mode:
authororbea <[email protected]>2022-05-12 18:34:52 -0700
committerRobert Antoni Buj Gelonch <[email protected]>2022-08-04 11:42:17 +0200
commitcb9e62b6d101cb42cdcf3ec7617616e6c4a4bb35 (patch)
tree4eedcb0776c740cec4f557ef161de956fc038438 /backends/alsa/Makefile.am
parentfc47f17a919e0320c1fa9aa24ab008540d9b2991 (diff)
downloadlibmatemixer-cb9e62b6d101cb42cdcf3ec7617616e6c4a4bb35.tar.bz2
libmatemixer-cb9e62b6d101cb42cdcf3ec7617616e6c4a4bb35.tar.xz
backends: Add missing dependencies
When building the backends with slibtool they will fail with undefined references to libmatemixer.la. This is because they use -no-undefined which slibtool explicitly supports while GNU libtool will silently ignore it. Gentoo Bug: https://bugs.gentoo.org/785232
Diffstat (limited to 'backends/alsa/Makefile.am')
-rw-r--r--backends/alsa/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/backends/alsa/Makefile.am b/backends/alsa/Makefile.am
index 798ce8b..44990b5 100644
--- a/backends/alsa/Makefile.am
+++ b/backends/alsa/Makefile.am
@@ -43,6 +43,7 @@ libmatemixer_alsa_la_SOURCES = \
alsa-types.h
libmatemixer_alsa_la_LIBADD = \
+ $(top_builddir)/libmatemixer/libmatemixer.la \
$(GLIB_LIBS) \
$(UDEV_LIBS) \
$(ALSA_LIBS)