summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJan Novotný <[email protected]>2022-11-07 15:32:33 +0100
committerGitHub <[email protected]>2022-11-07 15:32:33 +0100
commit2540175e5a5b15e65aecaf94a29f208e6a3836c9 (patch)
tree73859ebcfc550ed9edc04f66014250c89f3c1844 /meson.build
parentdb228e276fd4e7e7b33957d96cba73aaa4166a8d (diff)
downloadmarco-2540175e5a5b15e65aecaf94a29f208e6a3836c9.tar.bz2
marco-2540175e5a5b15e65aecaf94a29f208e6a3836c9.tar.xz
replace _NET_WM_PID with XResGetClientPid (#741)
window-props: use XResQueryClientIds to get pid _NET_WM_PID is unreliable! It can be faked or pid might be from different namespace. Ignore _NET_WM_PID and use XResQueryClientIds to get pid. https://gitlab.gnome.org/GNOME/metacity/-/commit/bcbe966511362a8eb8c8c64035ab160086c931f8
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index e777b6c6..199baa77 100644
--- a/meson.build
+++ b/meson.build
@@ -153,12 +153,14 @@ gtk_req = '>= 3.22.0'
pango_req = '>= 1.2.0'
libcanberra_gtk_req = '>= 3.22.0'
startup_notification_req = '>= 0.7'
+xres_req = '>= 1.2.0'
glib_dep = dependency('glib-2.0', version: glib_req)
gtk_dep = dependency('gtk+-3.0', version: gtk_req)
gio_dep = dependency('gio-2.0', version: gio_req)
pango_dep = dependency('pango', version: pango_req)
libcanberra_gtk_dep = dependency('libcanberra-gtk3')
+xres_dep = dependency('xres', version: xres_req)
x11_dep = dependency('x11')
marco_deps = [
@@ -167,6 +169,7 @@ marco_deps = [
gio_dep,
pango_dep,
libcanberra_gtk_dep,
+ xres_dep,
]
marco_message_deps = [