summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authormonsta <[email protected]>2016-11-01 21:12:07 +0300
committermonsta <[email protected]>2016-11-01 21:12:07 +0300
commit7ab2ca013c976a12830ae525df1c7cb66222c0ea (patch)
tree2056543e5166579bf9eff57735c1f6c194e7b547 /configure.ac
parent80d37475904c9e58b8a291bcd6d49867dbf23506 (diff)
downloadmate-control-center-7ab2ca013c976a12830ae525df1c7cb66222c0ea.tar.bz2
mate-control-center-7ab2ca013c976a12830ae525df1c7cb66222c0ea.tar.xz
build: require XInput unconditionally - same as done in m-s-d
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 5 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 4b2df496..61a38245 100644
--- a/configure.ac
+++ b/configure.ac
@@ -240,17 +240,11 @@ fi
CAPPLET_LIBS="$CAPPLET_LIBS $XCURSOR_LIBS"
-dnl =============================================
-dnl X Input library >= 1.2 with property support
-dnl =============================================
-have_xinput=no
-PKG_CHECK_MODULES(XINPUT, [xi >= 1.2],
- have_xinput=yes
- AC_DEFINE(HAVE_XINPUT, 1, [Define if the XInput extension is available]),
- have_xinput=no)
-AM_CONDITIONAL(HAVE_XINPUT, [test $have_xinput=yes])
-AC_SUBST(XINPUT_CFLAGS)
-AC_SUBST(XINPUT_LIBS)
+dnl ======================
+dnl X Input library >= 1.5
+dnl ======================
+
+PKG_CHECK_MODULES(XINPUT, xi >= 1.5)
CAPPLET_LIBS="$CAPPLET_LIBS $XINPUT_LIBS"
@@ -374,5 +368,4 @@ echo "
Appindicator: ${enable_appindicator}
Libmate-slab: ${have_libmateslab}
XCursor support: ${have_xcursor}
- XInput support: ${have_xinput}
"