summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authormonsta <[email protected]>2016-11-02 15:38:24 +0300
committermonsta <[email protected]>2016-11-02 15:38:24 +0300
commitb90041cb958032b3307eb19e0fd37831d54c5d9a (patch)
treebb5c034f7cab7e19d3947bf67ed7fc9cad090b82 /configure.ac
parent7ec8dfe386585a28257a443bcc5c47d937c741fb (diff)
downloadmate-control-center-b90041cb958032b3307eb19e0fd37831d54c5d9a.tar.bz2
mate-control-center-b90041cb958032b3307eb19e0fd37831d54c5d9a.tar.xz
build: require XCursor unconditionally
and drop bundled cursor files (.pcf) - they are not used at all when XCursor library is in use
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 3 insertions, 26 deletions
diff --git a/configure.ac b/configure.ac
index 61a38245..e9f95e94 100644
--- a/configure.ac
+++ b/configure.ac
@@ -212,31 +212,9 @@ DISPLAY_CAPPLET_LIBS="$DISPLAY_CAPPLET_LIBS"
CAPPLET_LIBS="$CAPPLET_LIBS $x_libs"
MATECC_LIBS="$MATECC_LIBS $x_libs"
-dnl
-dnl Check for XCursor support. If it exists, then we compile the
-dnl mouse capplet with support for it turned on
-dnl
-have_xcursor=no
-PKG_CHECK_MODULES(XCURSOR, [
- xcursor
- ],
- have_xcursor=yes
- AC_DEFINE(HAVE_XCURSOR, 1, [Define if the Xcursor extension is available]),
- have_xcursor=no)
-AM_CONDITIONAL(HAVE_XCURSOR, [test $have_xcursor=yes])
-AC_SUBST(XCURSOR_CFLAGS)
-AC_SUBST(XCURSOR_LIBS)
-
-if test x$have_xcursor = xyes; then
- AC_MSG_CHECKING([for XCURSOR cursor location])
- XCURSOR_ICONDIR=$($PKG_CONFIG --variable=icondir xcursor)
- if test "x$XCURSOR_ICONDIR" != x; then
- AC_DEFINE_UNQUOTED(XCURSOR_ICONDIR, "${XCURSOR_ICONDIR}", [Define to the xcursor icon path])
- else
- XCURSOR_ICONDIR=none
- fi
- AC_MSG_RESULT([${XCURSOR_ICONDIR}])
-fi
+PKG_CHECK_MODULES(XCURSOR, xcursor)
+XCURSOR_ICONDIR=$($PKG_CONFIG --variable=icondir xcursor)
+AC_DEFINE_UNQUOTED(XCURSOR_ICONDIR, "${XCURSOR_ICONDIR}", [Define to the xcursor icon path])
CAPPLET_LIBS="$CAPPLET_LIBS $XCURSOR_LIBS"
@@ -367,5 +345,4 @@ echo "
GTK+ API version: ${GTK_API_VERSION}
Appindicator: ${enable_appindicator}
Libmate-slab: ${have_libmateslab}
- XCursor support: ${have_xcursor}
"