summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorinfirit <[email protected]>2015-09-11 13:34:12 +0200
committerinfirit <[email protected]>2015-09-12 14:53:19 +0200
commit996c9d79f9391aef5f7459a073112cf8dc86518a (patch)
treed915643da800e08f8512ad5ee1a8f7f6261ca999 /configure.ac
parent24e4cdad34bfc9f6234bcb49c26eb093a8016aa0 (diff)
downloadmate-polkit-996c9d79f9391aef5f7459a073112cf8dc86518a.tar.bz2
mate-polkit-996c9d79f9391aef5f7459a073112cf8dc86518a.tar.xz
Optionally use accountsservice to retrieve face
Patch by Marc Deslauriers taken from https://bugzilla.gnome.org/show_bug.cgi?id=669857 Modified by infirit for MATE Thanks to raveit who pointed it out.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3d4b8d4..ab27fba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -158,6 +158,12 @@ PKG_CHECK_MODULES(POLKIT_GOBJECT, polkit-gobject-1 >= $POLKIT_GOBJECT_REQUIRED)
AC_SUBST(POLKIT_GOBJECT_CFLAGS)
AC_SUBST(POLKIT_GOBJECT_LIBS)
+AC_ARG_ENABLE([accountsservice],
+ AC_HELP_STRING([--enable-accountsservice], [Enable accountsservice]),,
+ [enable_accountsservice=yes])
+
+AM_CONDITIONAL([HAVE_ACCOUNTSSERVICE], [test "x$enable_accountsservice" = xyes])
+
AC_ARG_ENABLE([examples],
AC_HELP_STRING([--enable-examples], [Build the example programs]),,
[enable_examples=yes])
@@ -233,6 +239,7 @@ echo "
cppflags: ${CPPFLAGS}
Gtk+ version: ${GTK_API_VERSION}
+ Accountsservice: ${enable_accountsservice}
Maintainer mode: ${USE_MAINTAINER_MODE}
Building api docs: ${enable_gtk_doc}
GObject Introspection: ${enable_introspection}